• Как интегрировать PowerDNS в Active Directory?

    poisons
    @poisons
    DNS Conditional Forwarding. Первой ссылкой в гугле. Штатная возможность ms dns.
    Ответ написан
  • DHCP выдаёт много адресов на один MAC?

    hint000
    @hint000
    у админа три руки
    У вас на сервере поднята роль RAS и работает DHCP Relay Agent, который в качестве посредника выдаёт адреса клиентам. Если погуглить, то обнаружится, что аналогичный вопрос на разных форумах задавали неоднократно, по крайней мере с 2004 года. Даже в ответах прямая ссылка на статью Microsoft уже прокисла, так что вот из архива:
    https://web.archive.org/web/20120421065815/http://...
    Плюс это: https://www.google.com/search?q=dhcp+relay+agent+w...
    Ну и как найти ответ:
    60aae052d852c739172191.png
    Ответ написан
  • Судимость - крест на будущем?

    PleasantNews
    @PleasantNews
    Застрял из-за КОВИД-19 в Бангкоке. Класс, да?
    В HR кадровичку схватит удар - когда увидит "судимость". Им пофик за что, просто судимость - это реальный крест даже в средней компании. Тем более если там есть СБ - тогда вообще но пассаран.
    Проще разрулить с военкомом, чем потом всю жизнь доказывать, что "служат" слуги, а "выполняют долг" должники, и рабство отменили на Руси в 1861 году. Половина будет просто боятся, а ещё найдутся тупые "патриоты" ...
    Короче решай вопрос с военкомом, или нанять хорошего адвоката.
    Ответ написан
  • Как собрать программу (несколько вопросов)?

    @acwartz
    Тут должна быть ваша реклама.
    Имя файла это имя проекта, можно изменить в менеджере проектов:
    5f896f9c34249105669309.png

    Расположение выходного файла меняется в настройках проекта,
    обратите внимание на наличие вагона конфигураций:
    5f896fb08365a536392909.png

    Я для output directory для all values - all platforms указываю ..\bin\, там и плодятся все бинарники.
    Но это у меня т.к. структура проектов всегда такая:
    ./prjects//bin/.exe
    ./prjects//source/DCU/{Platform}/{BuildMode}/
    ./prjects//source/.dproj
    3) В настройках проекта указал лого и иконку(почему то у exe'шника и в трее они не меняются) - их(иконки) нужно так же около exe файла держать?

    С лого и прочим тоже самое, для каждого конфига нужны свои настройки.
    Иконка в трее берется из соотв. свойства компонента.

    4)Еще такой вопрос - как лучше хранить настройки по умолчанию?(сейчас они просто прописаны в коде) Была мысль - ini файл рядом с exe положить, но среди настроек есть некоторые "секретные", поэтому нужно, чтобы обычный пользователь их не трогал и не видел - нормальное ли решение будет добавить dll в котором прописать функцию устанавливающую эти настройки(например логин, пароль, адрес сервера куда отправляются запросы)
    обычные настройки(автозапуск, горячие клавиши) записываю в реестр.

    Вдумайтесь, настройки по-умолчанию это те настройки которые есть всегда вне зависимости от доступности реестра/файлов. Они должны быть внутри самого exe, т.е. прямо в коде прописаны либо модулем с константами/функциями. И не надо городить ни в ресурсах ни рядом ни в dll ничего, никаких конф. файлов. Это лишняя и пустая трата времени, в 95% случаев вы туда только в первый раз полезете и всё.

    5) Нужно ли сжимать exe файл с помощью upx?

    И зачем это нужно делать? Чтобы лишний раз панику пользователю развести на пустом месте из ничего?
    Если задаётесь этим вопросом, ответ - НЕ НУЖНО. Соберите Release и всё.

    6) С помощью чего создать инсталлятор? сильно ли критичный вариант создать sfx-архив с exeшником, файлом реестра и dll файлам?.

    А точно нужен этот инсталлятор?
    Батника Uninstall с командой start /wait yourapp.exe --uninstall недостаточно? Программа запустится, найдет аргумент вычистит все свои данные, и завершится. Батник грохнет свою папку и себя. Всё.

    Инсталлятор нужен когда приложение очень много файлов ставит в т.ч. в систему (системные библиотеки, масса записей в ресстр). Если очень хочется модно/молодёжно, то создавайте при помощи InnoSetup.
    Ответ написан
  • Как управлять локальной сетью своим роутером?

    anthtml
    @anthtml
    Системный администратор программист радиолюбитель
    IPTV, телефонию, охрану провайдеры обычно гоняют по отдельным VLANам с разводкой на access порты роутера, так что обычно ничего не мешает перевести только подключение интернета в бридж и поднимать его на своем
    Ответ написан
  • Какие современные бекап решения можно использовать вместо bacula/bareos?

    @rionnagel
    ковырятель
    veeam, если влезете в бесплатную версию, либо если бюджет позволяет. А так бакула.
    Ответ написан
  • Существует ли реальный шанс вычислить злоумышленника?

    profesor08
    @profesor08
    Существует ли реальный шанс вычислить злоумышленника?

    Да. Это тот человек, которому поднасрал автор вопроса. Если есть трудности с определением, то таких много, а значит заслужено. Надо терпеть и ждать когда прекратится. Либо рискнуть через органы и суд, но тут есть риск, что все может обернуться наоборот.
    Ответ написан
  • Какой сервер хранения данных выбрать?

    leahch
    @leahch
    Я мастер на все руки, я козлик Элек Мэк :-)
    Рекомендую посмотреть в сторону распределенных хранилищ, в частности - собрать CEPH-кластер. Серверов у вас много. Вы их свяжете между собой 10G сетью, поставите iSCSI на раздачу, а в некоторых случаях, если клиенты будут под linux, то и напрямую подключите. Будет у вас распределенное хранилище на все диски сразу. Можно будет сделать и кеширование на SSD, и прозрачное добавление дисковых ресурсов, и прозрачное восстановление и кучу всего хорошего.
    Есть, правда, небольшие требования к серверам, по гигабайту RAM на терабайт диска. Если втыкаете 24 диска по терабайту, то ставите 24 гига памяти. Но это не проблема. При этом вам совсем будут не нужны RAID-карты, достаточно обыкновенных HBA и экстендеров. За каждым диском отдельно будет следить и администрировать сам CEPH. Он же будет делать дублирование и распределение данных по дискам и серверам кластера. Производительность будет заведомо лучше, чем при записи на отдельный сервер, так как запись.чтение происходит параллельно на несколько серверов кластера.
    Дополнительно получите снапшоты, гибкость управления и очень хорошую отказоустойчивость.
    Ответ написан
  • Как настроить проброс портов при балансировки Mikrotik PCC?

    Melkij
    @Melkij
    PostgreSQL DBA, contributor
    Если у вас не только в prerouting стоят первые 4 правила, но и в таблице маршрутизации созданы routing mark соответствующие, то картина ничем не отличается от одного аплинка. Эти правила как раз и обеспечивают ответ на входящее соединение именно на тот канал, откуда запрос пришёл.

    Я для удобства в nat завёл цепочку port_forward, в которую перебрасывал пакеты по правилам in-interface=ether2 и in-interface=ether3. А в этой цепочке уже обычный форвардинг без привязки к реальному интерфейсу.

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether3-gw0
    add action=masquerade chain=srcnat out-interface=ether4-gw1
    add action=jump chain=dstnat in-interface=ether3-gw0 jump-target=port_forwarding_udp protocol=udp
    add action=jump chain=dstnat in-interface=ether4-gw1 jump-target=port_forwarding_udp protocol=udp
    add action=jump chain=dstnat in-interface=ether3-gw0 jump-target=port_forwarding_tcp protocol=tcp
    add action=jump chain=dstnat in-interface=ether4-gw1 jump-target=port_forwarding_tcp protocol=tcp
    add action=dst-nat chain=port_forwarding_udp dst-port=6891 protocol=udp to-addresses=192.168.5.20
    add action=dst-nat chain=port_forwarding_tcp dst-port=80 protocol=tcp to-addresses=192.168.7.10

    Если с какого-то аплинка порт остаётся закрыт, попробуйте попинговать сам роутер. Если пингов нет на том же самом провайдере - разбирайтесь с routing-mark. Я не раскурил в своё время, как работает эта магия с check-gateway 8.8.8.8.
    Ответ написан
  • Лицензирование CAL лицензий Windows Server и SQL Server, верно ли?

    CityCat4
    @CityCat4
    Если я чешу в затылке - не беда!
    Ответ на оба вопроса "нет". Лицензии на продукт могут использоваться только с той версией продукта, для которой они были куплены. Было время, я специально консультировался с девушкой из softline, с которой мы разбирались в том, сколько и чего нам понадобится...

    Лицензии от "старшей" версии может быть можно было бы использовать в "младшей". Лицензии от "младшей" в "старшей" - точно нет - ведь иначе Вы их не купите :D

    КапитализЪм...
    Ответ написан
  • Настройка фильтрации трафика в корпоративной сети - NAT vs FIREWALL, как лучше?

    edinorog
    @edinorog
    Троллей не кормить!
    0_о это ж сколько нужно было выпить чтоб задать такой вопрос. И с каких пор нат стал фильтровать трафик вообще?

    NAT (от англ. Network Address Translation — «преобразование сетевых адресов») — это механизм в сетях TCP/IP, позволяющий преобразовывать IP-адреса транзитных пакетов.
    ---------------------------------------------------------------------------------------------------------------
    Межсетево́й экра́н, сетево́й экра́н, файерво́л, брандма́уэр — комплекс аппаратных или программных средств, осуществляющий контроль и фильтрацию проходящих через него сетевых пакетов в соответствии с заданными правилами.
    Основной задачей сетевого экрана является защита компьютерных сетей или отдельных узлов от несанкционированного доступа. Также сетевые экраны часто называют фильтрами, так как их основная задача — не пропускать (фильтровать) пакеты, не подходящие под критерии, определённые в конфигурации.
    Некоторые сетевые экраны также позволяют осуществлять трансляцию адресов — динамическую замену внутрисетевых (серых) адресов или портов на внешние, используемые за пределами ЛВС.

    Я надеюсь у вас не высшее образование? А то вашему преподу стоит повеситься от горя.
    Ответ написан
  • Несколько вопросов о сетях IP-телефонии?

    ifaustrue
    @ifaustrue
    Пишу интересное в теллеграмм канале @cooladmin
    Итак, давай по-порядку.

    1. На картинке телефоны не включены в сеть провайдера, а включены в локальную сеть, в отдельный порт маршрутизатора, который уже отвечает за выдачу IP адресов для них.
    2. Судя по тому, что в этой схеме нет АТС, значит телефоны подключаются к облачному провайдеру. Т.е. АТС всегда есть, просто в данном случае, для упрощения, она не указана.
    3. Раз есть АТС (а она точно есть), телефоны подключаются к ней (она может быть локално или где-то. Может поддерживать SIP \ H323 аппараты напрямую или через VoIP шлюзы) и она уже отвечает за маршрутизацию вызовов, за связь с городской АТС, за приземление входящих линий (опять же - потоком напрямую или же по SIP).
    4. Раз номера приземлены на АТС, то позвонить на них можно так же как на обычный номер. Городская АТС смаршрутизирует вызов на эту офисную АТС, а она, в свою очередь, передаст его на соответствующий телефонный аппарат зарегистрированный в системе или на группу. Аппарат зазвонит.
    5. Если в вашем контроле есть АТС - то настройте её на регистрацию новых аппаратов и всё. Если нет поддержки VoIP - ставите шлюз на аналоговые \ цифровые линии и к шлюзу уже подключаете аппараты. Если АТС управляете не вы - то её в любом случае нужно настроить. А вот провайдеру ваших внешних линии не важно кто и как у вас их терминирует. Для простоты понимания для вашей городской АТС все телефоны находятся как бы за NAT и что с ними вы делаете за границой этого NAT ему не важно.
    Ответ написан
  • Какие есть программы для шифрования и удаления данных при вводе неверного пароля?

    leahch
    @leahch
    Я мастер на все руки, я козлик Элек Мэк :-)
    truecrypt - есть как минимум второй пароль для защищенного "раздела". Если пароль выпытывают паяльником, даем пароль от левого "раздела". Стирание - только аппаратное, так как злоумышленник всегда может скопировать защищенный контейнер и хоть обподбираться паролей.
    Ответ написан