• Как подключить домофон к умному дому?

    zamboga
    @zamboga
    #Запускаю стартапы
    1. Погуглите "модуль сопряжения для домофона". Стоит много дешевле осциллографа, может кто из знакомых-родственников их к вам закинет, дальше поиграетесь на месте. Важно: они немного разные под разные системы, так что надо "угуглиться" в глубину или покупать парочку на тестирование.
    2. Обычные домофоны на своем борту имеют самые обычные AV-сигналы. Т.е. берёте любой ТВ, и через "тюльпаны" подключаете, смотрите/слушаете. Для адресных (координатных) систем (а у вас, походу, как раз такой) -- нужен модуль сопряжения из п.1 (после него вы и получите обычные "аналоговые" сигналы на свой тестовый монитор из ТВ)
    Ответ написан
    Комментировать
  • Появился значок безопасного извлечения и можно извлечь основной жесткий диск, что не так? Может воткнул не туда?

    hint000
    @hint000
    у админа три руки
    Ничего страшного. Можете игнорировать эту странность.
    А так посмотрите в BIOS, там бывает настройка (отдельно для каждого порта SATA) горячего подключения диска. Попробуйте там выключить эту возможность.
    Upd.:
    Возможно, эта настройка была у вас на одних портах включена, на других выключена. А при переборке вы воткнули диск в другой порт, отсюда и такое изменение.
    Ответ написан
    Комментировать
  • Какой конфигурации нужен ноут для комфортной локальной разработки в Дата Саенс?

    @mayton2019
    Bigdata Engineer
    В свете последних трендов разработки - тебе нужен аккаунт в AWS или Azure и вот эти штуки


    Мощность "твоей" мясорубки для DataScince не должна иметь никакого значения. Продуктовые pipelines все равно будут работать не на ноутбуках а на специфичном железе с поддержкой TPU.

    Более того. Никакие "твои" специфичные железяки не должны превалировать над качеством модели на выходе.

    Поэтому покупай себе самый обычный ноутбук и не парь мозги. Излишек денег потрать на облачные подписки.
    Ответ написан
    Комментировать
  • Как поменять ttl на прошивке openwrt???

    Energoblock
    @Energoblock
    Geek
    В файл /etc/firewall.user
    В самый конец добавить строчку:
    iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65
    Ответ написан
    6 комментариев
  • Можно-ли заряжать Bluetooth-наушники от ПК?

    15432
    @15432
    Системный программист ^_^
    Абсолютно без разницы. 5 вольт они и в Африке 5 вольт
    Ответ написан
    Комментировать
  • Можно-ли заряжать Bluetooth-наушники от ПК?

    a_volkov1987
    @a_volkov1987
    Инженер-схемотехник опытного производства
    что от этого будет нашуникам

    Наушники будут заряжаться
    некоторые пишут, что так аккум быстрее умрет
    Многие пишут. Немногие внятно аргументируют то, что пишут.

    Итог: можно, заряжайте.
    Ответ написан
    Комментировать
  • Объединение филиалов через VPN на Mikrotik?

    @mr_welk
    Хоть вопрос и старый, отпишусь ,может кому и надо. Использую L2TP + IpSec на микротиках с поддержкой аппаратного шифрования. Работает стабильно. И никогда не используйте в работе сети 192.168.0.0/16 - они годятся только для дома, да и то, лучше взять 172-ю. Для рабочих сетей берите 172.16.0.0/12 или 10.0.0.0/8. Потом понадобится сделать VPN с сеткой из 192 подсети, в которой Вы не можете поменять адресацию, получите геморрой :)
    Ответ написан
    Комментировать
  • Как сделать блокировку пользователя через время в Mikrotik?

    Удобнее всего будет, если использовать hotspot для авторизации пользователей. Тогда, используя User Manager, можно задать время валидности профиля
    https://wiki.mikrotik.com/wiki/Manual:User_Manager...
    Ответ написан
    4 комментария
  • Как настроить QoS для потоковых данных (видеоконференции) на mikrotik?

    @DKarasev
    На основе ответа выше и данных по портам с сервера Zoom:

    /ip firewall mangle
    add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=3478-3479 new-connection-mark=VOIP passthrough=no protocol=udp
    add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=8801-8802 new-connection-mark=VOIP passthrough=no protocol=udp
    add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=8801-8802 new-connection-mark=VOIP passthrough=no protocol=tcp
    add action=mark-packet chain=prerouting comment=VOIP connection-mark=VOIP new-packet-mark=VOIP passthrough=no

    /queue tree
    add name=queue1 parent=wan-interface priority=1 queue=default
    add name=queue2 packet-mark=VOIP parent=queue1 priority=2 queue=default
    add name=queue3 packet-mark=no-mark parent=queue1 priority=8 queue=default
    Ответ написан
    Комментировать
  • Что лучше использовать для "безшовного" WIFI, Mikrotik или Ubiquiti?

    @MHEMOHuK
    Wi-Fi нормально работает как у Ubiquitu так и у MikroTik, только у первых оно работает с коробки, а у вторых - с бубном.

    В одном чатике телеграма недавно человек хорошо расписал по сути "бесшовного" роуминга:

    tl;dr Его не существует. Смиритесь.

    "Ололо, или "Бесшовный роуминг в 802.11 аКа Wi-Fi"
    или "Как маркетологи продают, а неучи верят"

    Краткие тезисы и пояснения сути.

    Клиент ищет точки, куда можно подключаться
    Клиент решает, когда переподключаться
    Клиент решает, куда подключаться
    Клиент инициирует переподключение
    Клиент выбирает, на какую частоту подключаться (2.4 или 5ггц)

    АП может:
    - Отвечать с задержкой на запросы аутентификации от клиента (как одна из реализаций band-steering, например)
    - Отказывать в аутентификации клиенту (по силе сигнала, при большой нагрузке на АП и тп)
    - Де-аутентифицировать клиента (должно использоваться как "крайняя мера".
    - Предоставлять клиенту оптимизированный список соседних АП для роуминга - 802.11k
    - Предоставлять информацию о загруженности других АП 802.11v
    - Ускорять процесс роуминга, используя "быструю аутентификацию" заместо полного процесса переаутентификации - 802.11r

    При этом, kvr - совершенно не обязательны и требуется поддержка оного и клиентом, и АП

    (пояснения специально упрощены для простого понимания, желающим глубже окунуться - читайте стандарты)

    Во всём этом, "МОЖЕТ" - ключевое слово. Несмотря на все вышеперечисленное, именно клиент решает, куда и как он хочет подключаться, и его решения могут целиком и полностью не совпадать с "рекомендациями и желаниями", полученными от АП. Потому что так решили те, кто писал драйвера и прошивку модуля.

    Отсюда появляются Типичные ситуации:
    - АП де-аутентифицирует\не аутентифицирует клиента. Он продолжает попытки коннекта к "старой" АП. Потому что хочет. Роуминга не происходит. Вифи у клиента не подключается.
    - Игнорирование клиентом одной из частот (2.4 или 5ггц) просто потому, что у него где-то внутри стоит приоритет одной из.

    Как "последнее слово" и итог: "Бесшовного" роуминга в 802.11 аКа Wi-Fi не существует в принципе. Максимум - "быстрый роуминг на стероидах". Повлиять на поведение клиента мы не можем от слова никак, лишь надеяться на адекватность его драйверов\прошивки.

    Как таковой "настоящий" роуминг, который "handover" - в 802.11 отсутствует и не предусмотрен стандартом.
    Ответ написан
    Комментировать
  • Существуют ли ноутбуки, на которые хорошо ставится Hackintosh?

    Virel
    @Virel
    цифровой художник
    Есть целый сайт торгующий ноутами с хакинтошем, гуглите) Конкретно завязка на процессоре и видюхе. Видюха не старая нужна встроенная и проц интел от i5 и выше. Целерон у меня так и не заработал. На i5 встаёт хорошо с интел HD средней производительности. На ноу-нейме есть целый список ноутов, куда хакинтош поставился без труда. В вк есть целая группа,посвящённая установке хакинтоша и там по-моему тоже есть список. В своё время пыталась на своего задохлика установить, но железо оказалось неподходящим. :(
    Ответ написан
    4 комментария
  • Есть эцп и крипто-про, как подписать файл онлайн через сайт?

    AItF4
    @AItF4
    Помог ответ? Отметь решением.
    Подписывать удобно в системе Контур https://crypto.kontur.ru/ только там регистрироваться нужно, а без регистрации подписать можно через сайты:
    Или программой Криптоарм, но она платная.
    Ответ написан
    Комментировать
  • Как решить проблему с tcp connection established на mikrotik?

    Buchachalo
    @Buchachalo Автор вопроса
    "Проблема", если её можно так назвать, решена. Клиент pptp был камера на столбе + TL-MR3220 (с OpenWRT) + Мегафоновский свисток E3372h в HiLink.
    В один прекрасный момент камера выжрала свой лимит в 30 Гб в месяц, трафик перестал ходить, но мегафон не просто отрубает интернеты, а как я понял снижает скорость до минимальной, так что HELLO-пакеты приходят, но на большее не хватает.

    Начался новый месяц, добавили трафик на аккаунт, и все прекрасно заработало.
    Ответ написан
    Комментировать
  • Роутер со встроенным 3G/4G модемом?

    ValdikSS
    @ValdikSS
    В Turris Omnia есть 3 порта mini-pcie, в которые можно вставить LTE-модемы.
    У Huawei есть домашние LTE-маршрутизаторы (и портативные тоже).
    Ответ написан
    Комментировать
  • Как определить, совместим ли роутер с 4g антенной?

    delphinpro
    @delphinpro
    frontend developer
    Для начала берете MIMO антенну и кабель. Например такую. Я брал с разъемом SMA, чтобы при необходимости можно было использовать пигтейлы.

    Далее смотрим на LTE модем. Если у него есть штатные разъемы для внешней антенны, то все просто — читаем инструкцию, берем соответствующий пигтейл, подключаем. Если штатных разъемов нет, то придется разобрать модем. На его плате должны быть технологические разъемы для антенны типов TS9 или CRC9 (типы почти одинаковые, одни диаметром 3.5, вторые 3 мм).
    Следует помнить, что разъемов должно быть два, а не один (поддержка MIMO).
    В зависимости от того, с какими разъемами вы приобрели антенну, покупаете пигтейл (переходник) от этого разъема на разъем модема. Например, такой, в моём случае.

    Все это колхозите в какой-нибудь корпус.
    Подключаете антенну и пользуетесь.

    Разумеется, никто вам не разрешит в магазине, перед покупкой, разобрать устройство для идентификации разъемов. Более того, разборка сразу же лишает вам гарантии, помните об этом. Тут остается только поискать информацию об интересующей вас модели в интернете, прежде чем отдавать за нее свои кровные.

    Вот такой колхоз с вышеупонятуыми по ссылкам компонентами и Yota модемом обеспечивает меня 20-30 мегабитами стабильного инета:

    5cf6850d19749512151349.jpeg
    Ответ написан
    Комментировать
  • Mikrotik: выбор «дорожного» роутера. Что и насколько сложно можно сделать?

    Night_Snake
    @Night_Snake
    Сети, микротики, циски и все, что рядом
    1. Хватит. Не загнется.
    2. Возможностей хватит, уровни лицензии ограничивают только количество туннелей/VPN-соединений. Но есть свои нюансы… Мануалов в интернете тысячи, один из сайтов вот тут:
    самореклама

    3. Документация вменяемая, но по некоторым особенностям придется читать howto, чтобы не изобретать велосипедов
    Ответ написан
    Комментировать
  • Как тестировать верстку?

    alone_lion1987
    @alone_lion1987
    Веб-разработчик
    Статья habrahabr.ru/post/114256

    1. Проверка соответствия макету.
      Допускается расхождение до 5px для текста. Разрешены и даже приветствуются правки размеров и расположения криво нарисованных блоков (разница размерах в 1-2px на разных страницах).
      В качестве инструмента можно использовать Pixel Perfect (см. статью).

    2. Кроссбраузерность. Корректное отображение в браузерах, указанных в задаче на тестирование.
    3. Проверка на всех необходимых разрешениях
      Всегда следует проверять, как страница реагирует на уменьшение масштаба, таким образом, эмулируя просмотр на устройстве с большим экраном.
      Особенно это актуально, если на странице есть фоновая картинка, которая должна быть на всю область экрана. Это позволяет проверить, что она не вставлена с обрубками.

    4. Проверка на всех необходимых устройствах.
      Даже сайты, не адаптированные под мобильное устройство, должны на нем более-менее корректно смотреться. На мобильных устройствах следует проверять хотя бы в двух браузерах.
      Интересный сервис: webmark.com.ua/mobile
      Можно средствами браузера.
      Адаптивная верстка - рекомендую бутстрап, getbootstrap.com

    5. Отсутствие js-ошибок. В консоли браузера не должно выдаваться ошибок.
    6. Валидация html - validator.w3.org/. Наличие предупреждений (Warning) при проверки возможно. Ошибок не должно быть.
    7. Валидация css.
    8. Корректная работа при вбивании реального текста, надёжность вёрстки.
    9. Оптимизация скорости загрузки.
      https://gtmetrix.com/
      https://developers.google.com/speed/pagespeed/insights/

    10. Наличие Win/Mac/Linux-аналогов шрифтов. При использовании нестандартных шрифтов (определить подгрузку таких шрифтов - также в консоли на закладке Network), проверить, что в случае их незагрузки сайт нормально смотрится.
      Как эмулировать их незагрузку? Например, если шрифт грузится с google fonts, закрыть к нему доступ через файл hosts. Сайт будет смотреться иначе, но ничего не должно слишком сильно разваливаться.

    11. Label и input/select должны быть слинкованы
    12. Проверка корректности заполнения форм на JS. В верстке формы должны валидироваться: обязательные поля подсвечиваться, поле email проверяться на корректность и т.п. Поля для ввода телефона должны иметь маску (если телефон, скорее всего, российский), возможно маски на другие поля (дата, время).

    13. Переключение между элементами форм по кнопке tab
    14. Лого на внутренних страницах должно вести на главную страницу (должно быть ссылкой)
    15. Интерактивность соответствующих элементов - реакция на наведение и нажатие
    16. Skype-плагин не должен ломать вёрстку
    17. Ресайз textarea не должен ломать вёрстку
    18. Ссылки на сторонние сайты должны быть с target=”_blank” (открываться в новой вкладке)
    19. Проверка орфографии, в том числе автоматизированными средствами (Word'ом)
    Ответ написан
    1 комментарий
  • Настройка OpenNIC на роутере mikrotik?

    TerAnYu
    @TerAnYu
    Системный администратор
    Актуальное решение на сегодня.
    С версии 6.47 добавили в DNS функцию split-dns, поэтому новый конфиг выглядит так:
    /ip dns static add comment="OpenNIC - dns relay" forward-to=185.121.177.177,51.15.98.97,2a01:4f8:1c0c:80c9::1 regexp=".*(\\.bbs|\\.chan|\\.cyb|\\.dyn|\\.geek|\\.gopher|\\.indy|\\.libre|\\.neo|\\.null|\\.o)\$" type=FWD
    /ip dns static add comment="OpenNIC - dns relay" forward-to=185.121.177.177,51.15.98.97,2a01:4f8:1c0c:80c9::1 regexp=".*(\\.oss|\\.oz|\\.parody|\\.pirate|\\.opennic.glue|\\.dns\\.opennic\\.glue)\$" type=FWD
    /ip dns static add comment="OpenNIC - dns relay" forward-to=185.121.177.177,51.15.98.97,2a01:4f8:1c0c:80c9::1 regexp=".*(\\.bazar|\\.coin|\\.emc|\\.lib|\\.fur1|\\.bit|\\.ku|\\.te|\\.ti|\\.uu)\$" type=FWD

    где 185.121.177.177,
    51.15.98.97,
    2a01:4f8:1c0c:80c9::1
    адреса серверов OpenNIC.

    Старое решение

    Делал так:
    /ip firewall layer7-protocol add comment="OpenNIC - dns relay" name=OpenNIC regexp="^.+(.bbs|.chan|.cyb|.dyn|.geek|.gopher|.indy|.libre|.neo|.null|.o|.oss|.oz|.parody|.pirate|.opennic.glue|.dns.opennic.glue).*\$"
    /ip firewall nat add action=dst-nat chain=dstnat comment="OpenNIC - dns relay" connection-mark=OpenNIC-forward to-addresses=185.121.177.177
    /ip firewall nat add action=masquerade chain=srcnat comment="OpenNIC - dns relay" connection-mark=OpenNIC-forward
    /ip firewall mangle add action=mark-connection chain=prerouting comment="OpenNIC - dns relay" dst-address=192.168.254.1 dst-port=53 layer7-protocol=OpenNIC new-connection-mark=OpenNIC-forward passthrough=yes protocol=tcp
    /ip firewall mangle add action=mark-connection chain=prerouting comment="OpenNIC - dns relay" dst-address=192.168.254.1 dst-port=53 layer7-protocol=OpenNIC new-connection-mark=OpenNIC-forward passthrough=yes protocol=udp


    192.168.254.1 - адрес своего роутера, который указан в качестве DNS на клиенте.
    185.121.177.177 - адрес резолвера ( https://wiki.opennic.org/doku.php#anycast_tier_2_d... )

    P.S.
    Возможно RegExp написан неправильно, ибо делал методом тыка.
    Ответ написан
    2 комментария
  • На каком носителе хранить важную информацию?

    ipswitch
    @ipswitch
    IT-инженер
    Если не заморачиваться с лентами, то ДВА или ТРИ жёстких диска надёжных серий РАЗНЫХ производителей РАЗНЫХ партий.

    Если будете брать внешние жёсткие диски, то не берите готовые USB-диски, а купите ноутбучный диск 2.5 дюйма SATA и дешёвый внешний бокс-адаптер USB-SATA.
    В подавляющем большинстве готовых USB-дисков WD, Seagate, Toshiba контроллер USB сейчас припаян прямо на диск. И это слабое место. Если сломается интерфейс или разъём, достаточно будет извлечь диск из коробочки и подключить обычным шлейфом к ПК.
    Ответ написан
    1 комментарий
  • На каком носителе хранить важную информацию?

    Облако. У любого физического носителя есть срок годности.
    Ответ написан
    7 комментариев