• Какой MikroTik способен маршрутизировать 10G?

    https://wiki.mikrotik.com/wiki/Manual:CRS3xx_serie...
    Но годно ли оно для продакшна - есть большие сомнения. Ибо RouterOS v7 only (которая все еще бета).
    Ответ написан
    Комментировать
  • Какую операционную систему выбрать для маршрутизатора?

    Тут скорее всего L3-свич нужен, а не софт-роутер. Хотелось бы узнать, исходя из каких потребностей нужен именно маршрутизатор.
    Ответ написан
    Комментировать
  • Как создать бесконечную компиляцию в терминале (как у хакеров)?

    bashtop
    atop 1
    Ответ написан
    Комментировать
  • Почему регистрация проходит с внешним ip?

    Правила NAT проверьте на микротиках, возможно где-то трафик натится там, где не должен. Если между Asterisk и телефонами нет NAT, то попробуйте выключить на микротиках обработку sip в разделе IP -> Firewall -> Service Ports. Но если Asterisk использует sip-транки в Интернет, то это может повлиять на их работу.
    Ответ написан
    Комментировать
  • Нужен консольный проигрыватель интернет-радио под Linux с хотя бы каким-то интерфейсом. Есть варианты?

    Наверное, можно было бы использовать VLC с включенным web-интерфесом и отключенным обычным. Только плейлист со станциями нужно будет подготовить заранее.
    https://wiki.videolan.org/Documentation:Modules/ht...
    https://wiki.videolan.org/Interfaces/
    Также у него есть консольный интерфейс (ncurses)
    Ответ написан
    Комментировать
  • Можно ли восстановить данные с raid 10?

    Если RAID аппаратный (10-й уровень подразумевает, что это скорее всего так), то можно снять образ всего массива и натравить R-Studio на него.
    Ответ написан
  • Как запустить выполнение действия в скрипте Mikrotik в зависимости от записи в логах?

    Если реально нужно перехватывать события в логах реалтайме, то можно придумать один способ, правда весьма извратный и расточительный. Нужно настроить отсылку логов Syslog на локальный адрес роутера, в правилах файрвола в цепочке создать правило, которое будет перехватывать нужное сообщение с логами (по полю Content) и создавать динамическую запись address-list, а в шедулере проверять наличие такой записи и по её появлении делать какие-то действия.
    Концепт-конфиг, которой отслеживает появление в логе отправленной из какого-либо скрипта или командной строки строчки "testtest" (правила файрвола должны быть до правила, разрешающего трафик established+related):
    # создаем интерфейс, на который можно повесить ip-адрес
    /interface bridge add name=logging-bridge
    # создаем локальный ip-адрес, на который будем слать Syslog
    /ip address add address=127.0.0.2 interface=logging-bridge
    # прописываем Syslog-сервер, на который будут отправляться логи
    /system logging action add name=remote2logwarch remote=127.0.0.2 target=remote
    # задаем отправку логов ни этот сервер, в topics прописываем нужные разделы вместо script
    /system logging add action=remote2logwarch topics=script
    # создаем правило, которое создает запись в address-list при наличии нужной подстроки в полученном syslog-пакете
    /ip firewall filter add action=add-src-to-address-list address-list=_logwatch_testtest address-list-timeout=1m chain=input content=testtest dst-address=127.0.0.2 dst-port=514 protocol=udp
    # создаем шедулер, который проверяет наличие нужной записи в address-list и выполняет какие-либо действия
    /system scheduler add interval=1s name=logwatch_testtest_1sec on-event=":if [ /ip firewall address-list find where dynamic && list=\"_logwatch_testtest\" ] do={ /ip firewall address-list remove [find dynamic && list=\"_logwatch_testtest\"]; /log info \"log entry catched!\" }\r\n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=jan/01/2021 start-time=00:00:00
    Ответ написан
    Комментировать
  • Что Microsoft TMG умеет такого, что не может MikroTik?

    Mikrotik - это в первую очередь роутер, функционал прокси-сервера там тоже есть, но достаточно скудный. А TMG - это именно прокси+файрвол, серверное решение, c интеграцией в AD, отчетами, и т.д., ориентированный именно на разграничение доступа и безопасность.
    Только вот поздновато вы про TMG вспомнили.
    "9 сентября 2012 Microsoft объявила о прекращении дальнейшего развития Forefront TMG. Основная поддержка будет прекращена после 14 апреля 2015 года, а расширенная поддержка закончится 14 апреля 2020 года. Продукт не будет доступен для приобретения после 1 декабря 2012 года[2]. На сегодняшний день доступен только в составе аппаратных решений OEM партнёров Microsoft. "
    Ответ написан
    Комментировать
  • Как создать графическое приложение для Windows?

    Судя по вопросу, вы начинаете изучать программирование с самых азов. Если нет цели осваивать конкретно C++ и Visual Studio, попробуйте Delphi / Lazarus (да, меня закидают тапками и др. предметами, но для того, чтобы быстро создать приложение-форму, принимающее и возвращающую данные, это один из самых удобных вариантов). Первый частично бесплатен, второй полностью.
    Но вообще с вычислительными задачами бывает удобнее работать в MS Excel или LibreOffice Calc, чем писать для этого отдельное приложение.
    Ответ написан
    2 комментария
  • Как в Proxmox использовать для VM другой ip?

    post-up         iptables -t nat -A POSTROUTING -s '10.0.0.0/24' -o vmbr0 -j MASQUERADE
    pre-down        iptables -t nat -D POSTROUTING -s '10.0.0.0/24' -o vmbr0 -j MASQUERADE


    Попробуйте вместо -j MASQUERADE подставить -j SNAT --to-source [ip2]
    Ответ написан
  • Mikrotik: пропадает пинг до шлюза по кабелю. В чем может быть причина?

    Сколько всего устройств в сети, с учетом WiFi-клиентов? У провайдеров может быть ограничение на количество mac-адресов, одновременно допустимых в L2 VPN. Поэтому всегда лучше на концах таких каналов держать какие-то свои маршрутизаторы, которые будут инкапсулировать передаваемый трафик. Хорошо бы уточнить у провайдера у провайдера этот момент.
    Если есть техническая возможность, попробуйте точки CAP использовать в этом качестве (завернув трафик локалки например в EoIP), хотя бы для теста, у них два проводных интерфейса, насколько я помню. Кстати CAPSMAN в зависимости от настроек тоже может инкапсулировать трафик WiFi-клиентов.
    Ответ написан
    3 комментария
  • Почему подсети не видят друг друга?

    В IP -> Route -> Rules добавьте перед тем правилом, которое на скриншоте, еще одно правило, в котором в dst-address будут адреса второй локальной сети, а в table - дефолтная таблица маршрутизации (main)
    Ответ написан
    Комментировать
  • Какой LTE модем идеально совместим с Mikrotik?

    Озадачивался недавно тем же самым вопросом, необходимо было заказать несколько десятков LTE-модемов для работы с роутерами Mikrotik. Huawei E3372h-320 точно так же отпал. Взяли на тест Alcatel IK41VE1, в течение месяца отработал стабильно, без проблем. Совместим с RouterOS начиная с 6.48. Из минусов - нет возможности нормально мониторить параметры сотовой сети (уровень сигнала отображается только в виде "палок" в веб-интерфейсе). Заявленный потребляемый ток - 400 ма, так что нагрузочной способности USB-портов должно хватать на любых устройствах.
    UPD. Как выяснилось, у модема есть скрытые настройки и диагностика, доступные по прямым ссылкам. Список тут - https://disk.yandex.ru/i/vOw5wsDEOSWNLg
    Ответ написан
    6 комментариев
  • Почему для скриптинга в шелле используется bash а не более современный язык программирования?

    Попробуйте сами поработать интерактивно и, надеюсь, все сразу станет понятно:
    sudo useradd -m perluser -s /usr/bin/perl && sudo -u perluser -i

    sudo useradd -m phpuser -s /usr/bin/php && sudo -u phpuser -i
    Ответ написан
    1 комментарий
  • Какие есть системы удаленного стола и оказания ХД?

    RMS Удаленный доступ
    https://rmansys.ru/remote-access/
    Ответ написан
    Комментировать
  • Совместимые трансиверы 10Gbps, для Cisco, Hpe?

    Одинаковые трансиверы разумеется не нужны. В Cisco ставите совместимый с Cisco, в HP - совместимый с HP. Главное, чтобы они реализовывали один и тот же физический стандарт передачи по оптоволокну семейства 10GBASE-XX (и были совместимы по частотам). Для линка в один метр нет разницы, что использовать - синглмод и мультимод, более того, на таком расстоянии обычно можно использовать оптический патчкорд с многомодовым волокном даже с одномодовыми SFP-модулями.
    А проще и дешевле всего было бы взять медный кабель Direct Attach, если бы удалось найти тот, который будет совместим с обоими коммутаторами.
    Ответ написан
    Комментировать
  • Можно ли соединить между собой два SFP-трансивера на 3 и 20 км?

    Если они совместимы по используемому стандарту оптики и частотам, то как правило можно.
    Ответ написан
  • Какие существуют адекватные способы предотвратить сбрасывание SSH тунелей?

    Не очень понял, как все это у вас работает, но вариант навскидку - создавать при поднятии ssh-соединения с помощью plink также фейковый порт-форвардинг через соответствующий параметр командной строки и каким-либо образом периодически пытаться его задействовать, хотя бы простейшей вызываемой из шедулера командой вроде
    echo | telnet localhost PORT
    Ответ написан
    2 комментария
  • Нет Wi-Fi на Windows XP, какие проблемы?

    Если Windows XP без обновлений, то на ней не будет поддержки WPA2. Для него нужно либо установить Service Pack 3, либо отдельно обновление KB893357. Может быть тут дело в этом?
    Ответ написан
  • Сколько PPPOE сеccий поддерживает MIKROTIK?

    Емкость таблицы mac-адресов и некоторые другие параметры коммутаторов Mikrotik можно посмотреть по ссылке https://help.mikrotik.com/docs/display/ROS/CRS3xx+...
    Для CRS354-48G-4S+2Q+ это значение составляет 32000.
    Ответ написан
    Комментировать