Как выгрузить из Mikrotik с помощью скрипта определенные поля в файл?

Выгрузка в консоль выглядит как

foreach a in=[/ip dhcp-server lease print as-value where !static] do={:put ($a->"address" ."\t". $a->"mac-address" ."\t". $a->"last-seen" ."\t". $a->"host-name")}


как-то запихнуть в файл не вышло, пробовал вот так

:local buffer ""
:local fileContents ""

foreach buffer in=[/ip dhcp-server lease print as-value where !static] do={
:local leaseInfo ($buffer->"address" . "\t" . $buffer->"mac-address" . "\t" . $buffer->"last-seen" . "\t" . $buffer->"host-name")
:set fileContents ($fileContents . $leaseInfo . "\n")
}

/file set "1dhcp" contents=$fileContents


Где ошибка? как решить вопросик?
  • Вопрос задан
  • 211 просмотров
Решения вопроса 1
execute "foreach a in=[/ip dhcp-server lease print as-value where !static] do={:put (\$a->\"address\" .\"\t\". \$a->\"mac-address\" .\"\t\". \$a->\"last-seen\" .\"\t\". \$a->\"host-name\")}" file=1dhcp

Проверено в RouterOS 7.10.1, работает.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы