partyzanx
@partyzanx

Как в EXCEL совместить строчки из двух табличек?

Помогите, пожалуйста, совмещать строчки из табличек AJ12:AO62 и AP12:AU62 и вставлять строчки их в AV12:BA62
Файл https://yadi.sk/i/n-WMHhqOf_XVXw

Есть формула, но она совмещает только столбцы из заданного диапазона
Формула массива:
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЗ($W$11:W11)<=СЧЁТЕСЛИ($S$12:$S$62;"?*");ИНДЕКС(S:S;НАИМЕНЬШИЙ(ЕСЛИ($S$12:$S$62<>"";СТРОКА($S$12:$S$62));СТРОКА(1:1)));ИНДЕКС(U:U;НАИМЕНЬШИЙ(ЕСЛИ($U$12:$U$62<>"";СТРОКА($U$12:$U$62));СТРОКА(1:1)-СЧЁТЕСЛИ($S$12:$S$62;"?*"))));"")

5c85c860965c8945134279.png

Должно получиться объединение двух табличек в одну без пустых строк

5c85f3971fe2b016193769.png

Я сделал такую формулу в ячейке AV12
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЗ($AV$11:AV11)<=СЧЁТЕСЛИ($AJ$12:$AJ$62;"?*");ИНДЕКС(AJ:AJ;НАИМЕНЬШИЙ(ЕСЛИ($AJ$12:$AJ$62<>"";СТРОКА($AJ$12:$AJ$62));СТРОКА(1:1)));ИНДЕКС(AP:AP;НАИМЕНЬШИЙ(ЕСЛИ($AP$12:$AP$62<>"";СТРОКА($AP$12:$AP$62));СТРОКА(1:1)-СЧЁТЕСЛИ($AJ$12:$AJ$62;"?*"))));"")

Вводить ctrl+shift+enter

Но часть данных пропадает (выделено красным облаком)
Файл с этой формулой https://yadi.sk/i/wKvrbIsARehJCA
5c85fbfc2c365040584553.png
  • Вопрос задан
  • 75 просмотров
Решения вопроса 1
Volounteer
@Volounteer
Формула почти правильная. Нужно убрать закрепление столбца вот тут:
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЗ($AV$11:AV11)
То есть должно быть:
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЗ(AV$11:AV11)

Файл с поправленной формулой тут
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы