@idsergey_alexandrov

Как разделить входящий трафик по портам на mikrotik?

Есть 2 интернета нужно чтобы по первому шел трафик по одним портам, а по второму другой по другим портам5a45e5c87c0a2030153452.png
  • Вопрос задан
  • 949 просмотров
Решения вопроса 1
p00h
@p00h
Фехтовальщик-стропальщик
/ip route add dst-address=0.0.0.0/0 gateway=1.2.3.4 routing-mark=ISP1-r
/ip firewall mangle add chain=prerouting dst-port=80 protocol=tcp action=mark-connection new-connection-mark=ISP1-с
/ip firewall mangle add chain=prerouting connection-mark=ISP1-c action=mark-routing new-routing-mark=ISP1-r

где 1.2.3.4 - шлюз провайдера 1.

Данный набор правил направит весь трафик на 80 порт через ISP1
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@Gansterito
Такое разделение чревато. Если разделять по портам удаленного сервера, то запрос на 80ый порт может придти с одного IP (через первый канал), а на 443 - с другого (второй канал). Если брать локальные порты - аналогично, с одного локального ПК может быть установлено две TCP-сессии с одним и тем же сервером, но с разных адресов. Что-то может пойти не так, особенно, если cookie на сайте привязываются к IP-адресам.
Альтернативные варианты - разделить "весь интернет" (0.0.0.0/0) на две почти равные части - 0.0.0.0/1 и 128.0.0.0/1, и смаршрутизировать их через разных провайдеров.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы