p00h
@p00h
Фехтовальщик-стропальщик

Mikrotik: queues без ограничения пропускной способности канала?

Добрый день, коллеги!

Довольно давно и успешно работаю с микротиками, но сегодня возник вопрос, который сумел поставить в тупик.
До сегодняшнего дня вопрос с приоритезацией трафика и ограничением пропускной способности канала основывался на стабильной (плюс-минус полмегабита) скорости.

А сейчас я имею крайне нестабильный канал, а хочется хотя бы по приоритетам траффик разделить, не урезая пропускную способность.

Другими словами, будет ли реально работать разделение на 1 и 8 приоритет с такими правилами?
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 name=qos_1 packet-mark=qos_1 parent=global-total priority=1
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 name=qos_8 packet-mark=qos_8 parent=global-total priority=8
  • Вопрос задан
  • 4594 просмотра
Решения вопроса 1
@JDima
А как вы себе это представляете с алгоритмической точки зрения?

Любые политики приоритезации трафика вступают в дело, когда переполняются очереди на интерфейсах и надо делать выбор, кто из пакетов выживет, а кто — нет. Либо физический интерфейс перегружен, либо применен шейпер для ограничения полосы. Если канал не перегружен, то все прилетевшие пакеты без затей уходят наружу. Как вы представляете себе приоритезацию в условиях, когда всем хорошо и все прекрасно влезают в канал? Дропать неприоритетные классы? «Нестабильный канал» = «потери где-то у провайдера», неконтролируемые, непредсказуемые…
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@Inquisitor
Используйте тип очереди PCQ.
Ответ написан
Комментировать
@jartashi
Во всяких howto обычно рекомендовали ставить шейпер на скорость чуть меньше физической и внутри уже приоритезировать.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы