@romashin0

Как исправить ошибку при установке mono?

scpuser@scp2:~$ sudo apt install mono-complete
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-runtime-sgen (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-llvm-support (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: libmono-2.0-1 (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-utils (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-devel (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-mcs (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-roslyn (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-csharp-shell (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-4.0-gac (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: mono-4.0-service (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: monodoc-base (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: monodoc-manual (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: libmono-cil-dev (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
                 Depends: referenceassemblies-pcl but it is not going to be installed
                 Depends: msbuild but it is not going to be installed
                 Depends: ca-certificates-mono (= 6.10.0.104-0xamarin16+debian10b1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
  • Вопрос задан
  • 232 просмотра
Пригласить эксперта
Ответы на вопрос 2
smorman
@smorman
When In Rome do as The Romans do...
А sudo apt install -f
не канает?
Ответ написан
Если изначально следуешь инструкции по установке
https://www.mono-project.com/download/stable/#down...
и при этом выводится ошибка о нехватающих зависимостей, то нужно сообщить о проблемах разработчикам Mono:
https://github.com/mono/mono/issues
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы