Mikrotik\RouterOS, VPN-туннель между двумя офисами, в каждом по два линка — как настроить?

Добрый день!

Есть офис, в нем резервирование ISP (1 и 2) и есть склад, в нем та же ситуация (ISP 3 и 4).

Тип туннеля - L2TP.

Резервирование - check-gateway=ping шлюза ISP.

После настройки (спасибо dannyzubarev), роутер отвечает на тот интерфейс, на который приходит запрос:

/ip firewall mangle
add chain=input in-interface=wan1-out action=mark-connection new-connection-mark=wan1
add chain=input in-interface=wan2-out action=mark-connection new-connection-mark=wan2
add chain=output connection-mark=wan1 action=mark-routing new-routing-mark=wan1     
add chain=output connection-mark=wan2 action=mark-routing new-routing-mark=wan2
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=wan1 
add dst-address=0.0.0.0/0 gateway=10.0.0.2 routing-mark=wan2


Т.е. снаружи через винбокс и пингом видны оба линка - и основной и резервный.

Офис служит L2TP-сервером.

К нему через активный в данный момент линк на складе должен подсоединяться VPN-туннель со склада.
Т.е. должны быть подняты одновременно два туннеля, один до ISP 1, второй до ISP2, а уже на роутерах указываются статические марштурты до внутренних сетей офиса и склада с разными distance.

Проблема:
Когда туннель один (до ISP 1 или 2, неважно) все хорошо. Стоит включить второй (секреты, маршруты, IP туннелей, все разное) - то первый отваливается, пытается дозвониться, но тут же отключается. А второй не поднимается вовсе.

Как это поправить?

VPN.jpg
  • Вопрос задан
  • 32407 просмотров
Пригласить эксперта
Ответы на вопрос 8
p00h
@p00h
Фехтовальщик-стропальщик
Поднять два тоннеля одного типа между двумя устройствами у вас не выйдет. Насколько я понимаю, Вы пытаетесь поднять два l2tp тоннеля, нужно один заменить на что-либо другое: ovpn, pptp...
Если ваша цель аггрегация каналов, то существует масса способов осуществить это, но самый правильный, на мой взгляд, - поднять два vpls поверх ваших vpn, которые способны обеспечить мосты между офисом и складом, а уже их, в свою очередь, объединить в bonding. Вот простейший пример.
Ответ написан
nimbo
@nimbo
а зачем два тунеля если можно один, но через активный в данный момент линк? 0_о
а вы не пробовали просто дистанс на 0.0.0.0 для isp1=1 для isp2=2 делать? почему спрашиваю - потому что не вижу как вы получаете конкретно интернет - pppoe\eth чистая статика или серый ip и т.п.
Ответ написан
На последнем МУМе разбирали подобную ситуацию. Считаю, что по ссылке более элегантное решение.
Сам использую Микротик почти в 20ти офисах, в некоторых из них по два канала.
Если у Вас всего пара офисов - то дальше первой главы не читайте, больше - обязательно используйте OSPF.
mum.mikrotik.com/presentations/RU14/cudin.pdf
Ответ написан
В микротике есть такая штука "Torch". Во время установки соединения посмотри от какого ISP идёт исходящий трафик и на какой принимается входящий.
В L2TP клиенте, насколько помню(Сижу с Макбука жены, сейчас подсмотреть негде), нет понятия "Local IP", из-за этого установление обоих соединений идёт через маршрут по умолчанию (если они с одинаковой метрикой, то с наименее загруженного ISP).
Если моё предположение подтвердится, тогда пробуй тунели типа GRE/IP Tunel/EoIP. Вообще делай OSPF поверх GRE/IP tunel, навешивай сверху IPSEC и не парься, работает стабильно, есть встроенные проверки состояния каналов, чем больше устройств - тем больше стабильность. Если нужна консультация по поводу динамической маршрутизации, могу помочь через Skype/TeamViever бесплатно.
Ответ написан
d1fef37f888c4a93b531a3b43fcdb6ed.png
в скрине демонстрация. Там должно быть два IP: 1 - с какого IP устанавливать соединение, 2 - на какой IP ожидать встречное соединение(Соединение равноправных участников, соединение "Сети с сетью")

GRE/IP Tunel/ EoIP - это просто другие типы тунелей имеющие свои плюсы и минусы, лично я их использую потому, что они более управляемые и на них легко делать динамическую маршрутизацию. Это соединения равноправных участников, где каждый является одновременно и клиентом и сервером.
habrahabr.ru/post/170895
Ответ написан
SmileyK
@SmileyK
Коротко не как
И снова к нашим медведям то если я делаю такую схему Вот то при обновлении DNS каждые 3 минуты я получаю обрыв верно ?
Ответ написан
@Uttar
У меня такая же ситуация.
Центральный офис - два канала, точки 1\2 канала.
На центральном микротике поднят l2tp сервер, в точках соответственно клиенты.
Необходимо, что бы при падении основного канала в офисе VPN переподключался на резервный канал.
Настроил через скрипт проверку доступности основного канала и при его падении гасится один l2tp-clinet интерфейс и поднимается другой (в котором вбит Connect To резервного интернета в центральном офисе). Это всё работает. Но при попытке инициализации VPN ругается "old tunnel is not closed yet" и не хочет ни в какую коннектиться. Не помогает удаление из активных соединений и из Connections в Firewall`е. Как только меняю обратно, всё замечательно поднимается.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы