Ruby/Как решить проблему с ошибкой сервера?

To see why this extension failed to compile, please check the mkmf.log which can
be found here:


extconf failed, exit code 1

Gem files will remain installed in
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.0 for
Results logged to

An error occurred while installing sqlite3 (1.4.0), and Bundler cannot continue.
Make sure that `gem install sqlite3 -v '1.4.0' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:

потом вот эта ошибка
Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.
  • Вопрос задан
  • 2304 просмотра
Пригласить эксперта
Ответы на вопрос 2
Проверь версию sqlite3. Попробуй установить версию 1.3.6, мне помогла в похожем случае.
Для этого укажи его версию явно:
gem 'sqlite3', '~> 1.3.6'
Ответ написан
Rails generally stays close to the latest released Ruby version when it's released:

Rails 5 requires Ruby 2.2.2 or newer.
Rails 4 prefers Ruby 2.0 and requires 1.9.3 or newer.
Rails 3.2.x is the last branch to support Ruby 1.8.7.
Rails 3 and above require Ruby 1.8.7 or higher. Support for all of the previous Ruby versions has been dropped officially. You should upgrade as early as possible.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы