@Rasul_qa

Как правильно установить и настроить falcon?

Доброго дня люди добрые!

Разворачиваю проект локально на ubuntu 18
Используется стек технологий: php7, nginx, falcon, mysql

Подскажите как правильно установить falcon, похоже я его как то криво ставлю :(
Прикрепил логи nginx, ругается на falcon...В php_info нет информации о нем.

2018/05/16 11:55:29 [error] 27822#27822: *28 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Class 'Phalcon\Config' not found in /var/www/html/backend/config/config.php:5
Stack trace:
#0 /var/www/html/backend/index.php(27): include()
#1 {main}
thrown in /var/www/html/backend/config/config.php on line 5" while reading response header from upstream, client: ::1, server: 127.0.0.1, request: "GET /app.css?v=1526373912940 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock:", host: "localhost", referrer: "localhost"
2018/05/16 11:55:29 [error] 27822#27822: *27 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Class 'Phalcon\Config' not found in /var/www/html/backend/config/config.php:5
Stack trace:
#0 /var/www/html/backend/index.php(27): include()
#1 {main}
thrown in /var/www/html/backend/config/config.php on line 5" while reading response header from upstream, client: ::1, server: 127.0.0.1, request: "GET /app.js?v=1526373912940 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock:", host: "localhost", referrer: "localhost"
  • Вопрос задан
  • 513 просмотров
Пригласить эксперта
Ответы на вопрос 3
alekciy
@alekciy
Вёбных дел мастер
Для ubuntu14/16, но по идее и на более новых версиях должно сработать:
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt-get install php7.0-phalcon
Ответ написан
catanfa
@catanfa
Похоже, Phalcon просто не установлен. Смотрите вывод phpinfo(); exit;
там должна быть информация о расширении Phalcon. Для установки следуйте инструкциям на официальном сайте.
Ответ написан
@VaniXac
17 лет
Частая ошибка, не соответствие самого расширения phalcon.dll и версии php.
Проверьте саму версию, и разрядность.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы