Как правильно построить маршрутизацию в микротик?

5a325017a26a6543988328.png
В общем есть сетка между 2 магазинами, сеть на микротиках.
Я создаю 2 PPTP туннеля с дома, со своего микротика - тоннель поднят, все хорошо - но вот есть проблема - т.к. у обоих узлов внутренняя сетка 192.168.0.0/24 (IP не пересекаются, между собой подсети видят все без проблем), то у меня 2 маршрута одновременно не работают, т.е. статус у одного из маршруток unreachable пока не отключу второй.
Можно ли что-то сделать, чтоб оба маршрута одновременно работали ? (сменить подсеть одного из узлов не предлагать - слишком много проблем)
  • Вопрос задан
  • 1494 просмотра
Пригласить эксперта
Ответы на вопрос 5
@TemperOK
Чем больше учишь, тем меньше знаешь.
сменить подсеть одного из узлов не предлагать - слишком много проблем


Зато по-людски и без костылей беспонтовых
Ответ написан
@vetash
Как уже подсказал Александр Карабанов вам нужен netmap.
Допустим у вас есть конечный хост у даленной сети 192.168.50.36 и вы хотите к нему обращаться по адресу 192.168.5.5
Тогда в nat вам нужно заремапить эти адреса таким образом:

/ip firewall nat
add action=netmap chain=dstnat disabled=yes dst-address=192.168.5.5 to-addresses=192.168.50.36
add action=netmap chain=srcnat disabled=yes src-address=192.168.50.36 to-addresses=192.168.5.5

Разумеется если вам необходимо отправлять пакеты в какой-то интерфейс - указываете его в правилах.

/ip firewall nat
add action=netmap chain=dstnat disabled=yes dst-address=192.168.5.5 in-interface=bridge1 to-addresses=192.168.50.36
add action=netmap chain=srcnat disabled=yes out-interface=bridge1 src-address=192.168.50.36 to-addresses=192.168.5.5

Вместо bridge1 - ваш впн туннель.
Ответ написан
Комментировать
karabanov
@karabanov
Системный администратор
С телефона неудобно писать, поэтому только ссылка https://forum.mikrotik.com/viewtopic.php?t=43569
Ответ написан
PPTP сделайте что бы ip были из другой подсети, а потом настройте eoip и будет вам радость.

https://nixman.info/?p=1347
Ответ написан
@Prez
Вот смотрю и думаю, а зачем вам два одновременно работающих подключения к одной и той же сети? У вас просто разнесенная сеть из двух точек, но она ОДНА. Вот и ходите в нее по одному из подключений (второе - резерв). У вас все должно быть доступно в обоих магазах (сетка то у них одна). Просто раз у вас два выхода в интернет из сети магазов, вам придется правильно настроить вход (обязательно натить оба адреса и src и dst), чтобы узлы другого магазина отвечали на зашедшее подключение, а не в свой шлюз по умолчанию.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы