Deerenaros
@Deerenaros
Программист, математик, задрот и даже чуть инженер

Должен ли быть segmentation fault при старте qtcreator?

Собственно, qtcreator не работает под archlinux. Система пол года не обновлялась, недавно после yaourt -Syu, много было замен, но не помню ничего про qt. Гугл несёт околесицу (или я не умею в него).

$ uname -a
Linux yuriy-thinkpad 4.10.13-1-ARCH #1 SMP PREEMPT Thu Apr 27 12:15:09 CEST 2017 x86_64 GNU/Linux

$ yaourt -Qs linux | grep -B1 "The Linux kernel"
core/linux 4.10.13-1 (base)
The Linux kernel and modules

$ yaourt -Qs qt
extra/pyqt5-common 5.8.2-2
Common PyQt files shared between python-pyqt5 and python2-pyqt5

extra/python2-pyqt5 5.8.2-2
A set of Python 2.x bindings for the Qt5 toolkit

extra/qt5-base 5.8.0-11 (qt qt5)
A cross-platform application and UI framework

extra/qt5-declarative 5.8.0-1 (qt qt5)
Classes for QML and JavaScript languages

extra/qt5-location 5.8.0-1 (qt qt5)
Provides access to position, satellite and area monitoring classes

extra/qt5-quickcontrols 5.8.0-1 (qt qt5)
Reusable Qt Quick based UI controls to create classic desktop-style user interfaces

extra/qt5-quickcontrols2 5.8.0-1 (qt qt5)
Next generation user interface controls based on Qt Quick

extra/qt5-script 5.8.0-1 (qt qt5)
Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility

extra/qt5-svg 5.8.0-1 (qt qt5)
Classes for displaying the contents of SVG files

extra/qt5-tools 5.8.0-1 (qt qt5)
A cross-platform application and UI framework (Development Tools, QtHelp)

extra/qt5-webchannel 5.8.0-1 (qt qt5)
Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients

extra/qt5-webengine 5.8.0-8 (qt qt5)
Provides support for web applications using the Chromium browser project

extra/qt5-xmlpatterns 5.8.0-1 (qt qt5)
Support for XPath, XQuery, XSLT and XML schema validation

local/qtcreator-git v4.3.0.beta1.r310.g9ee0cec3bc-1
Lightweight, cross-platform integrated development environment

$ qtcreator
Gen6+ requires Kernel 3.6 or later.
Segmentation fault (core dumped)


Есть подозрение, что не только qtcreator так себя ведёт, а весь qt, ибо
$ qtdiag
Gen6+ requires Kernel 3.6 or later.
Segmentation fault (core dumped)


Заранее благодарен.

P.S. Вопрос риторический.
  • Вопрос задан
  • 595 просмотров
Пригласить эксперта
Ответы на вопрос 2
@Gytim
У меня так ругалется когда я свои проги на qt запускаю, без библиотек, которые используются в проге. Может у вас тоже по версиям либ проблемы?
Ответ написан
vt4a2h
@vt4a2h
Senior software engineer (C++/Qt/boost)
Советую переставить QtCreator и системную Qt. Если не поможет, попробовать поставить creator не из репов, а обычным инсталлером, он почти полностью автономен и должен работать.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы