@Aspid1

Что не так с настройками Mikrotik и Cisco?

Есть Cisco WS-C3750-48poe и Микротик RB 951 и задача поднять центральный DHCP сервер и NAT на микротике? а маршрутизацию оставить на Cisco. Микротик с кошкой дружит через транк (влан2) друг друга видят. Входящяя от провайдера в Cisco (через нее транзитом до микротика проброшен влан с реальным IP), На микротике поднят DHCP (10.20.10.0/24) NAT (маскарад на влан с белым IP) и создана подсеть для одного влана (пока). На кошке настроен дхцп релей на микротик, проблема в том что микротик упорно не хочет раздавать адресса, пул адресов создан, запросы от кошки видно, но ответа от микротика нет, в чем может быть проблема, ткните пальцем

Настройки Cisco
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone Europe/Kiev 3
switch 1 provision ws-c3750-48p
system mtu routing 1500
ip subnet-zero
ip routing
no ip domain-lookup
ip domain-name R1.to
ip name-server 8.8.8.8
ip dhcp smart-relay
ip dhcp relay information option
ip dhcp relay information policy keep
no ip dhcp relay information check
ip dhcp relay information trust-all
!
!
ip dhcp-server 10.20.10.2
!
!
crypto pki trustpoint TP-self-signed-1661953024
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1661953024
 revocation-check none
 rsakeypair TP-self-signed-1661953024
!
!

!
port-channel load-balance src-dst-ip
!
!
!
spanning-tree mode pvst
spanning-tree loopguard default
spanning-tree extend system-id
no spanning-tree vlan 5-6,8
!
vlan internal allocation policy ascending
!
!
!
!
interface Port-channel1
 description Mikrotik-NAT
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 ip dhcp relay information trusted
 spanning-tree bpdufilter enable
 ip dhcp snooping trust
!
interface FastEthernet1/0/1
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/2
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/3
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/4
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!         
interface FastEthernet1/0/5
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/6
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/7
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/8
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/9
 switchport access vlan 7
 switchport mode access
 switchport priority extend trust
 switchport voice detect cisco-phone full-duplex
 mls qos trust cos
 spanning-tree portfast
!
interface FastEthernet1/0/44
 power inline never
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust
!
interface FastEthernet1/0/45
 power inline never
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust
!
interface FastEthernet1/0/46
 power inline never
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust
!
interface FastEthernet1/0/47
 power inline never
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust
!
interface FastEthernet1/0/48
 power inline never
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 3
 switchport trunk allowed vlan 3,8
 switchport mode trunk
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface Vlan1
 no ip address
 shutdown
 spanning-tree portfast
!
interface Vlan2
 ip dhcp relay information trusted
 ip address 10.20.10.1 255.255.255.0
 ip helper-address 10.20.10.2
!
interface Vlan3
 ip address 172.30.28.5 255.255.255.0
!
interface Vlan7
 description Voice
 ip address 172.16.0.1 255.255.255.0
 ip helper-address 10.20.10.2
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.20.10.2
ip route 172.30.0.0 255.255.0.0 172.30.28.1
no ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
 password 7 0500112E0D44542F
 login
line vty 5 15
 password 7 0500112E0D44542F
 login
!
ntp clock-period 36029241
ntp max-associations 1

end


Настройка Mikrotik
# jul/06/2016 12:41:29 by RouterOS 6.35.4
# software id = 0ZDA-MDT8
#
/interface bonding
add mode=802.3ad name=Cisco3750 slaves=ether1,ether2,ether3,ether4 \
    transmit-hash-policy=layer-2-and-3
/interface vlan
add interface=Cisco3750 name=Cisco-vl2 vlan-id=2
add comment="\D2\F0\E0\ED\E7\E8\F2 Cisco" interface=Cisco3750 name=\
    Real-IP-vl8 vlan-id=8
add interface=Cisco3750 name=Voice vlan-id=7
/ip neighbor discovery
set Real-IP-vl8 comment="\D2\F0\E0\ED\E7\E8\F2 Cisco"
/ip dhcp-server option
add code=66 name="Cisco CP7940" value="s'172.30.28.87'"
/ip pool
add name=dhcp_pool1 ranges=10.20.10.5-10.20.10.254
add name=172.16.0.0 ranges=172.16.0.2-172.16.0.254
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 always-broadcast=yes authoritative=\
    yes disabled=no interface=Cisco-vl2 name=dhcp1
add add-arp=yes address-pool=172.16.0.0 always-broadcast=yes authoritative=\
    yes disabled=no interface=Voice name=Voice src-address=172.26.0.2
/ip address
add address=10.20.10.2/24 interface=Cisco-vl2 network=10.20.10.0
add address=46.174.71.3/24 comment=\
    "\D1\F2\E0\F2\E8\F7\ED\FB\E9 ip \ED\E5 \F2\F0\EE\E3\E0\F2\FC" interface=\
    Real-IP-vl8 network=46.174.71.0
add address=172.26.0.2/24 interface=Voice network=172.26.0.0
/ip dhcp-server network
add address=10.20.10.0/32 dns-server=10.20.10.2 gateway=10.20.10.2 netmask=24
add address=172.16.0.0/32 dns-server=10.20.10.2 gateway=172.16.0.2 netmask=24 \
    ntp-server=172.30.7.2
/ip dns
set servers=10.0.0.6
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Real-IP-vl8
/ip route
add distance=1 gateway=46.174.71.1
add distance=1 dst-address=172.16.0.0/16 gateway=10.20.10.1
add distance=1 dst-address=172.30.0.0/16 gateway=10.20.10.1
/ip route vrf
add interfaces=Voice routing-mark=1
/ip upnp
set enabled=yes
/system clock
set time-zone-name=Europe/Kiev
/system leds
set 0 interface=wlan1
/tool romon
set enabled=yes
/tool traffic-generator
set test-id=1
  • Вопрос задан
  • 2881 просмотр
Решения вопроса 1
vasilevkirill
@vasilevkirill
Сертифицированный тренер MikroTik TR0417
Невнимательность
/ip dhcp-server network
add address=10.20.10.0/32 dns-server=10.20.10.2 gateway=10.20.10.2 netmask=24
add address=172.16.0.0/32 dns-server=10.20.10.2 gateway=172.16.0.2 netmask=24 ntp-server=172.30.7.2

А должно быть
/ip dhcp-server network
add address=10.20.10.0/24 dns-server=10.20.10.2 gateway=10.20.10.2 netmask=24
add address=172.16.0.0/24 dns-server=10.20.10.2 gateway=172.16.0.2 netmask=24 ntp-server=172.30.7.2


и укажите на микротике адрес релея в dhcp сервере.

Также объясните для чего вам такая конструкция?
/ip route vrf
add interfaces=Voice routing-mark=1
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@Aspid1 Автор вопроса
Я так понимаю для каждого влан нужно будет поднимать свой DHCP сервер ( и влан на микротике)? или можно указать только лишь подсети(пулы) и микротик их будет отдавать по запросу
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы