mcdemon
@mcdemon
Инженер сети ШПД

Каким образом Mikrotik/RouterOS знает ip адрес шлюза, если я задал в качестве шлюза физический интерфейс?

Беру я значит свеженький микротик с routeros 6.35.2
делаю ему полный reset конфига, без использования стандартного
то-есть получается "голый" конфиг без ip адреса

у меня есть подсеть 31.200.235.140/30
где 31.200.235.141 - шлюз циско, 31.200.235.142 - микротик

делаю на нем следующую конфигурацию
/ip address
add address=31.200.235.142/30 interface=ether1 network=31.200.235.140
/ip route
add distance=1 gateway=ether1

то-есть ip адрес шлюза я не указываю, я указываю физический интерфейс
вопрос, почему при такой конфигурации работает интернет? :) (например идет пинг на 8.8.8.8)
трассировка показывает 31.200.235.141 в качестве первого хопа, но как он узнал его?

я конечно понимаю, что мне как человеку не трудно догадаться, что шлюз это 31.200.235.141, но микротик не человек)
я конечно не соменваюсь, что это даже где-то описано в мануале микротика но не нашел сам :(
очень интересно какой механизм определения
и что будет если сеть например станет не /30, а /29
  • Вопрос задан
  • 1847 просмотров
Решения вопроса 1
Посмотрите /ip routes print
Шлюз по умолчанию появился? Думаю что нет.

Ответ кроется в самом вопросе. Шлюз CISCO. ПО умолчанию на интерфейсах у них включен proxy-arp.
С другим оборудованием - не факт что получится повторить указанную схему.
Ответ написан
Пригласить эксперта
Ответы на вопрос 4
@moneron89
Сертифицированный тренер Mikrotik
У циско включен прокси-арп на интерфейсах. Если вы заглянете в ip-arp, увидите, что куче ип-адресов сопоставлен один мак. Юзать эту фичу можно, но она поджирает оперативку. Поэтому я за классическую маршрутизацию. Маска подсети в данном случае не имеет значения, хоть /8
Ответ написан
@v_cirill
Если кратко, первый хоп был узнан по мак адресу за интерфейсом ether1

Более подробно КАК все этого работает - ответит модель OSI (второй уровнь сетевого взаимодействия).
Ответ написан
vvpoloskin
@vvpoloskin Куратор тега Сетевое администрирование
Инженер связи
Вам нужно почитать, как работает классическая статическая маршрутизация.

Маршрутизатор смотрит заголовок пакета, определяет DST IP адрес и ищет по таблице маршрутизации, в какой интерфейс послать пакет, при необходимости делая реккурсивные запросы к собственной таблице маршрутизации.
Ответ написан
NeiroNx
@NeiroNx
Программист
Маска 30 бит(из 32) - не оставляет ему выбора.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы