@csar
c++

Как обновить драйвер opengl в Debian?

Поставил в дебиан стим, скачал доту. Пытаюсь запустить - просит обновить opengl. Нашел в сети решение(askubuntu.com/questions/751324/failed-to-create-op..., добавил репозиторий, пытаюсь обновить.
Система выдает ошибку:

Failed to fetch https://pkg.tox.chat/debian/dists/nightly/InRelease  Unable to find expected entry 'bunsen-hydrogen/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/dists/bunsen-hydrogen/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/dists/bunsen-hydrogen/main/binary-i386/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/troorl/pino/ubuntu/dists/bunsen-hydrogen/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/troorl/pino/ubuntu/dists/bunsen-hydrogen/main/binary-i386/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/vala-team/ppa/ubuntu/dists/bunsen-hydrogen/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/vala-team/ppa/ubuntu/dists/bunsen-hydrogen/main/binary-i386/Packages  404  Not Found


Решил в sources.list удалить ненужные линки, смотрю:

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160210-22:53]/ jessie contrib main non-free
# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160210-22:53]/ jessie contrib main non-free
#deb http://httpredir.debian.org/debian jessie main non-free contrib
# deb-src http://httpredir.debian.org/debian jessie main non-free contrib
deb http://security.debian.org/ jessie/updates main contrib non-free
# deb-src http://security.debian.org/ jessie/updates main contrib non-free
# jessie-updates, previously known as 'volatile'
#deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
# deb-src http://httpredir.debian.org/debian jessie-updates main contrib non-free


Как исправить ошибку с обновлением?
  • Вопрос задан
  • 1537 просмотров
Решения вопроса 1
@csar Автор вопроса
c++
Проблема решена, в alsamixer снял флаг MM и все заработало
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
ValorVl
@ValorVl
DevOps
Насколько я знаю, либы OpenGL идут в составе драйверов видиокарт. Та же Nvidia с проприетарным драйвером тянет своий GL.. (GLX)
Так, что я струдом себе представляю как "обновить" OGL вне контекста драйверов.

Вот пример для nvidia
libgl1-nvidia-glx - NVIDIA binary OpenGL libraries
libgl1-nvidia-glx-i386 - NVIDIA binary OpenGL 32-bit libraries

Package: libgl1-nvidia-glx
Source: nvidia-graphics-drivers
Version: 340.96-1
Installed-Size: 44772
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Architecture: amd64
Replaces: libgl1-nvidia-glx-ia32, nvidia-glx-ia32
Provides: libgl1-nvidia-glx-340.96, libgl1-nvidia-glx-any
Depends: nvidia-alternative (= 340.96-1), nvidia-support, libc6 (>= 2.2.5), libx11-6, libxext6
Pre-Depends: debconf (>= 0.5) | debconf-2.0, pciutils, nvidia-installer-cleanup, multiarch-support
Recommends: nvidia-kernel-dkms (= 340.96-1) | nvidia-kernel-340.96
Suggests: nvidia-kernel-dkms (>= 340.96) | nvidia-kernel-source (>= 340.96)
Conflicts: libgl1-nvidia-glx-340.96, libgl1-nvidia-glx-ia32, libgl1-nvidia-glx-ia32-any, nvidia-glx-ia32
Breaks: ia32-libs (<< 1:0)
Description-en: NVIDIA binary OpenGL libraries
 These binary libraries provide optimized hardware acceleration of
 OpenGL applications via a direct-rendering X Server.
 .
 See the description of the nvidia-driver package
 or /usr/share/doc/libgl1-nvidia-glx/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.
Description-md5: db7a72cd04f077818b4b6d25c0a73de1
Multi-Arch: same
Homepage: http://www.nvidia.com
Section: non-free/libs
Priority: optional
Filename: pool/non-free/n/nvidia-graphics-drivers/libgl1-nvidia-glx_340.96-1_amd64.deb
Size: 7462146
MD5sum: ac85be7e5a1238b4b1ecf53fe8e3227b
SHA1: b2dcaf755fb1fe7ce86fd52a1dcca7d11ab89c3c
SHA256: 01051604cfbe212566a8d0e2a4b569f612cacdb941795dc4f3dffa8faf7cbe5d


ЗЫ! В Debian работает PPA ?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы