script88
@script88

Curses в Perl вылетают ошибки

Пытаюсь разобрать пример

#!/usr/bin/perl -w

use Curses::UI;
    my $cui = new Curses::UI;
    my $win = $cui->add('window_id', 'Window');
    my $listbox = $win->add(
        'mylistbox', 'Listbox',
        -values    => [1, 2, 3],
        -labels    => { 1 => 'One',
                        2 => 'Two',
                        3 => 'Three' },
        -radio     => 1,
    );

    $listbox->focus();
    my $selected = $listbox->get();


при запуске вылетает ошибки

[root@node2 BRmysql]# perl Curses.pl
Can't locate Curses/UI.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Curses.pl line 3.
BEGIN failed--compilation aborted at Curses.pl line 3.


perl-Curses.x86_64 — установлен

OS CentOS release 6.3 (Final) x86_64
  • Вопрос задан
  • 3308 просмотров
Решения вопроса 1
SLY_G
@SLY_G
журналист, переводчик, программист, стартапщик
Можно просто попробовать

perl -MCPAN -e 'install Curses::UI'
Ответ написан
Пригласить эксперта
Ответы на вопрос 3
kafeman
@kafeman
  1. Поищите UI.pm в указанных директориях (/usr/local/lib64/perl5, /usr/local/share/perl5, /usr/lib64/perl5/vendor_perl, /usr/share/perl5/vendor_perl, /usr/lib64/perl5, /usr/share/perl5).
    Если не найдете, значит не установился или установился не туда (тогда добавьте путь в INC).
  2. Если файл найдется, проверьте его права на чтение — у меня недавно была такая же ошибка из-за того, что программа не могла прочитать пакет.
Ответ написан
kafeman
@kafeman
  1. Поищите UI.pm в указанных директориях (/usr/local/lib64/perl5, /usr/local/share/perl5, /usr/lib64/perl5/vendor_perl, /usr/share/perl5/vendor_perl, /usr/lib64/perl5, /usr/share/perl5).
    Если не найдете, значит не установился или установился не туда (тогда добавьте путь в INC).
  2. Если файл найдется, проверьте его права на чтение — у меня недавно была такая же ошибка из-за того, что программа не могла прочитать пакет.
Ответ написан
Комментировать
kafeman
@kafeman
  1. Поищите UI.pm в указанных директориях (/usr/local/lib64/perl5, /usr/local/share/perl5, /usr/lib64/perl5/vendor_perl, /usr/share/perl5/vendor_perl, /usr/lib64/perl5, /usr/share/perl5).
    Если не найдете, значит не установился или установился не туда (тогда добавьте путь в INC).
  2. Если файл найдется, проверьте его права на чтение — у меня недавно была такая же ошибка из-за того, что программа не могла прочитать пакет.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы