Не могу запустить I2P, в чем проблема?

Отлично у меня работал. Запускал с консоли командой i2prouter start, через stop останавливал... Но однажды не захотел запускатся. Если не ошибаюсь, после того, как обновлял (не через пакетный менеджер, а так, когда в консоли в браузере писало что есть обновление). Я короч переставлял (удалял purg'ем) java, i2p, i2p-router, пробовал с чистым ~/.i2p но всегда результат один и тот же=( Вот вам немножко копипасты:
tolik ~ $ cat ~/.i2p/wrapper.log | tail -n43
2015/03/02 19:26:10 | wrapper  | ------------------------------------------------------------------------
2015/03/02 19:26:10 | wrapper  | Advice:
2015/03/02 19:26:10 | wrapper  | Usually when the Wrapper fails to start the JVM process, it is because
2015/03/02 19:26:10 | wrapper  | of a problem with the value of the configured Java command.  Currently:
2015/03/02 19:26:10 | wrapper  | wrapper.java.command=java
2015/03/02 19:26:10 | wrapper  | Please make sure that the PATH or any other referenced environment
2015/03/02 19:26:10 | wrapper  | variables are correctly defined for the current environment.
2015/03/02 19:26:10 | wrapper  | ------------------------------------------------------------------------
2015/03/02 19:26:10 | wrapper  | 
2015/03/02 19:26:10 | wrapper  | Launching a JVM...
2015/03/02 19:26:10 | 
2015/03/02 19:26:10 | ------------------------------------------------------------------------
2015/03/02 19:26:10 | Advice:
2015/03/02 19:26:10 | Usually when the Wrapper fails to start the JVM process, it is because
2015/03/02 19:26:10 | of a problem with the value of the configured Java command.  Currently:
2015/03/02 19:26:10 | wrapper.java.command=java
2015/03/02 19:26:10 | Please make sure that the PATH or any other referenced environment
2015/03/02 19:26:10 | variables are correctly defined for the current environment.
2015/03/02 19:26:10 | ------------------------------------------------------------------------
2015/03/02 19:26:10 | 
2015/03/02 19:26:25 | Launching a JVM...
2015/03/02 19:26:25 | JVM exited while loading the application.
2015/03/02 19:26:25 | Unable to start JVM: Відмовлено у доступі (13) // Отказано в доступе (WTF, что это?)
2015/03/02 19:26:25 |   Currently:
2015/03/02 19:26:25 | wrapper  | wrapper.java.command=java
2015/03/02 19:26:25 | wrapper  | Please make sure that the PATH or any other referenced environment
2015/03/02 19:26:25 | wrapper  | variables are correctly defined for the current environment.
2015/03/02 19:26:25 | wrapper  | ------------------------------------------------------------------------
2015/03/02 19:26:25 | wrapper  | 
2015/03/02 19:26:25 | wrapper  | Launching a JVM...
2015/03/02 19:26:25 | 
2015/03/02 19:26:25 | ------------------------------------------------------------------------
2015/03/02 19:26:25 | Advice:
2015/03/02 19:26:25 | Usually when the Wrapper fails to start the JVM process, it is because
2015/03/02 19:26:25 | of a problem with the value of the configured Java command.  Currently:
2015/03/02 19:26:25 | wrapper.java.command=java
2015/03/02 19:26:25 | Please make sure that the PATH or any other referenced environment
2015/03/02 19:26:25 | variables are correctly defined for the current environment.
2015/03/02 19:26:25 | ------------------------------------------------------------------------
2015/03/02 19:26:25 | 
2015/03/02 19:26:25 | There were 5 failed launches in a row, each lasting less than 300 seconds.  Giving up.
2015/03/02 19:26:25 |   There may be a configuration problem: please check the logs.
2015/03/02 19:26:25 | <-- Wrapper Stopped

Тем не менее, сама Ява отлично работает, работают и Android Studio и Minecraft... HELP SOS
  • Вопрос задан
  • 3535 просмотров
Решения вопроса 1
@ton1
java crap однако)
советую посмотреть на альтернативную реализацию
https://github.com/PurpleI2P/i2pd
// на правах оффтопа
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Gaskar Group Санкт-Петербург
от 130 000 ₽
Eltex Новосибирск
от 100 000 ₽
ProCloud Москва
от 80 000 ₽