Проблемы с ноутбуком под Ubuntu Linux 11.10

На днях приобрёл себе ноутбук MSI GE620DX-285XRU в качестве замены старенькому HP, более того весьма вкусная начинка предлагалась по цене в 26к рублей — Intel Core i5-2410M, NV GF 555M с 2 гигами выделенной памяти, 4 гига оперативной памяти и LED-матрица, полноценная клавиатура с клавишами островного типа, выделенный цифровой блок, да ещё и без напичканной крапварью ОС. В общем, почти мечта линуксоида (глянец, мать его, портит всё впечатление).

Ну, я естественно помчался ставить свою любимую убунту 10.10, но потом выяснилось, что в её ядре нет дров для адаптера беспроводной связи, после чего я махнул рукой, загрузил 11.10 и попытался поставить. Тут меня ждал провал — лайвсиди не запускался (к слову, 16 федора тоже не запускалась, запустился ещё дебиан линукс мин, но с глюками). Поразмыслив, я решил, что плясать с бубнами я привык над убунтой и принялся ставить её. Нежелание запускаться установщика я обошёл запуском с флагом nomodeset, после чего установка прошла как по маслу. Правда установленная система отказалась без этого флага запускаться, но в грабе я прописал параметр намертво, поэтому меня это не волновало. Начало волновать то, что ОС втолкнула VESA для отображения графики, поэтому разрешение 1024х768 меня нисколько не устроило, я полез в раздел проприетарных дров, где мне ОС радостно сообщила, что мне они не нужны. Тут я понял, что это виновато долбанутое пятое поколение новых видюх нвидии с долбанутым оптимусом, от которого толку не больше, чем от козла молока. Полез прописывать репы с тестовыми дровами нвидии (тестовыми для каноникала, естественно, нвидия 285 ветку пометила уже как стабильные), загрузил самые свеженькие стабильные дрова и перегрузился. Результата ноль, тогда я полез в NVIDIA Settings, там мне софтина выдала ошибку, мол, нет у тебя активированного оборудования, поэтому мы перезапишем x.org. Я согласился и опять перезагрузился. После чего меня ждала вот эта картина

Я как бы не понял, что мне хотела убунта этим сказать, но на случай я набрал контрлальтф1, и консоль tty1 вылезла. Особо я шаманить не стал, просто попробовал sudo lightdm restart (start), но ноль эмоций, после пары подмигиваний появилась вышепоказанная картина. Что мне делать?
Я подозреваю, что это софтина нвидии что-то записала в конфигурациях такое, что иксы легли намертво. Есть ли выход в этой ситуации? Куда копать? Если можно, то с командами. Лайвсиди и tty-консоль на месте и готовы к бою.
  • Вопрос задан
  • 3924 просмотра
Пригласить эксперта
Ответы на вопрос 7
shadowalone
@shadowalone
dpkg-reconfigure xserver-xorg от root-а
Ответ написан
FloppyFormator
@FloppyFormator
Если с самого начала была цель использовать на ноутбуке Linux, стоило учитывать этот момент при покупке.
Ответ написан
@Jazzist
Хрень какая-то… на эту машину убунту ставится из коробки.

— Версия «Десктоп»
— 10.10
— Обновиться полностью после установки
— Включить офф. multiverse репозиторий
— Обновить список пакетов
— «Система->Администрирование->Драйверы устройств», увидеть новый драйвер и установить его
— Перезапустить иксы

Окольных путей не предлагаю, ибо не катят они именно для данного случая.
Ответ написан
sledopit
@sledopit
А логи то, логи что пишут?
grep -E «EE|WW» /var/log/Xorg.0.log
прояснит картину.
Ответ написан
@Elkaz
Попробуйте удалить xorg.conf — после установки nvidia-current + nvidia-xconfig всегда помогает (у меня тоже ноутбук с этим дурацким оптимусом).
Ответ написан
frol
@frol
Линуксоид
С оптимусом не всё так хорошо как хотелось бы… Вот знания, которыми я обладаю:
1) Nvidia выводит изображение через Intel, поэтому отключить Intel не получится и, видомо поэтому, xorg нельзя запустиь на драйвере nvidia
2) Есть преокт ironhide (который продолжает дело bumblebee проекта). Ironhide имеет набор профилей настроек для разный ноутбуков (подробнее о профилях ничего не знаю). После уставноки ironhide можно запускать отдельные приложения на Nvidia. Запуск осуществляется через апплет или из командной строки: vglrun <команда>
3) В 3.1 ядре вроде как улучшили работу с оптимусом, но на чистом ядре я не смог его завести, и ironhide на 3.1 ядро не встал
4) Сам ковыряюсь с этим последнюю неделю и вот вчера только узнал о vglrun, у меня получились довольно парадоксальные результаты — glxgears показывает 400FPS, а vglrun glxgears — 200FPS… В принципе, у vglrun есть опции, с которыми я ещё совсем не игрался…
Ответ написан
rharunzade
@rharunzade
можно попробовать скачать драйвер с сайта нвидии и напрямую его установить. иногда помогает. правда перед этим апт-гет ремув пурге нивидиа*

так же можно прописать на время в хорг.конф вместо nvidia, vesa
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы