Akuma
@Akuma
Веб-программист

Какую версию Google Play Services использовать в Android Studio?

Добрый всем вечер,

есть Android Studio последней версии. Пытаюсь подключить в проект Google Play Services для использования Google Maps v3.

В dependencies для Gradle указываю:
compile 'com.google.android.gms:play-services:5.2.08'
т.е. последнюю версию.

Открываю приложение: "Сервисы не обновлены, обновите иначе ничего не запустится".
Жму кнопку - нет обновления. У меня на телефоне стоит версия 4 с копейками.
Так же проверял на планшете с более новым андройдом - все то же самое.

Пробую менять зависимость на
compile 'com.google.android.gms:play-services:4+'
Результат - все работает.

Вот собственно и запутался. Android Studio рекомендует использовать последнюю версию, Google в документации рекумендует использовать последнюю версию. Но она не работает же.

Что я делаю не так?
  • Вопрос задан
  • 4392 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы