@RonH

Интернет есть, страницы не грузятся — не DNS/proxy/hosts/тариф/кабель/etc, а что?

Анемез: ходил скомпа под Debian 9 в интернет через телефон Galaxy A3 2016 и usb-шнурок (режим модема в телефоне).
Купил новый телефон - Galaxy M62, android 11, One UI 3.1 (т.е. последние обновления) - рабоать перестал. Шнурок с микро-USB на Type-C обновил (это если кто шутуить изволит). В итоге имеем через шнурок на компе и на ноуте:
1. На телефоне интернет есть, тариф ("Связь Z" от Билайн) раздачу подразумевает, оператору звонил - всё ок, баланс >0, роуминг, покрытие, уровень сигнала сети - всё ОК.
2. Если раздавать через точку доступа WiFi тоже всё ок (проверено на нескольких смартфонах и ноутбуке с Debian 9).
3. USB кабель исправен: соединение стабильное, утилиты статистики наличие ошибок не показывают, можно смотреть видео и передавать большие файлы - всё ок.
4. Утилиты ping и *traceroute разного вида работают без замечаний, netstat, ifconfig, ethtool, networkctl, и т.д. ничего подознительного не выдают. Конфигурационные файлы не менялись, пробовал изменять ttl и mtu - без результата. Работает нативный клиент Telegram, входит в сеть DHT qBittorrent, лихо грузятся торренты по uTP соединению...
5. В целом (не специалист тут я) работает в текстовом режиме консольный браузер links2, в графическом текст грузит, а картинки частично (дудлы, например) или полсностью, если маленькие.
6. Firefox и Opera(chromium) грузят или очень лёгкие сайты или почти ничего - вечно ожидают окончания загрузки данных.
7. wget зависает в таком виде:
wget ya.ru
--2021-10-25 17:06:21-- ya.ru
Распознаётся ya.ru (ya.ru)… 87.250.250.242, 2a02:6b8::2:242
Подключение к ya.ru (ya.ru)|87.250.250.242|:80... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 302 Found
Адрес: https://ya.ru/ [переход]
--2021-10-25 17:06:22-- https://ya.ru/
Подключение к ya.ru (ya.ru)|87.250.250.242|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 Ok
Длина: 60496 (59K) [text/html]
Сохранение в: «index.html»

index.html 0%[ ] 0 --.-KB/s

8. Windows 10 на виртуальной машине VirtulalBox через NAT и Briged Adapter ведёт себя аналогично - пинги есть, страничек нет.

9. Гуглил весь день. Андроид по меню настроек весь проверил (на глаз) - замечаний нет.

Куда копать дальше - не знаю. Что скажете?
---------------
UPD: дополнение 1:
1. так работает: debian -- комп -- usb -- старый телефон -- wifi -- новый телефон -- 4g -- опсос.

2. метрика, вроде бы, тоже не влияет.
  • Вопрос задан
  • 155 просмотров
Пригласить эксперта
Ответы на вопрос 1
paran0id
@paran0id
Умный, но ленивый
похоже на проблему с MTU - настройки интерфейсов в студию
также попробуйте пропинговать внешний сервер большими пакетами
ping ya.ru -f -l 1450
уменьшая значение, если пинг не проходит
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы