• Возможно ли отображение дополнительной информации контакта при звонке на android?

    @topbanana Автор вопроса
    Нашел call notes pro, выполняет поставленную задачу.
    Ответ написан
    Комментировать
  • Почему ipsec тоннель поднимается, но трафик между сетями не проходит?

    @topbanana Автор вопроса
    С момента создания вопроса прошло уже много времени. С тех пор изменилась схема подключения и сами устройства. Но ошибка была, похоже, вот тут

    ip nat inside source static tcp 10.1.1.200 445 interface FastEthernet4 445
    ip nat inside source static tcp 10.1.1.200 139 interface FastEthernet4 139
    ip nat inside source static tcp 10.1.1.200 138 interface FastEthernet4 138
    ip nat inside source static tcp 10.1.1.200 137 interface FastEthernet4 137

    пока эти строки не изменились, трафик не шел и в туннеле между двух 871.
    Ответ написан
    Комментировать
  • Ошибка подключения cisco 871 к pptp серверу. В чем может быть проблема?

    @topbanana Автор вопроса
    Все оказалось просто. Пару дней назад закончилась абонплата. Пока я не разорвал соединение, оно спокойно себе работало.
    Ответ написан
    Комментировать
  • Почему не поднимается тоннель между cisco rv320 и cisco 871?

    @topbanana Автор вопроса
    включил deb crypto ipsec и deb crypto isakmp, включил на RV320 general log для IPSec & PPTP VPN и для SSL VPN.

    RV320 в логах пишет только вот это
    2014-07-04, 06:29:17	 VPN Log	 [g2gips0] #442: [Tunnel Established] ISAKMP SA established


    871 пишет вот что:
    Jul  4 14:38:08.250: ISAKMP:(1012):atts are acceptable.
    Jul  4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #1
    Jul  4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #1,
      (key eng. msg.) INBOUND local= 93.190.176.206, remote= 93.190.178.205, 
        local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4), 
        remote_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4),
        protocol= AH, transform= ah-sha-hmac  (Tunnel), 
        lifedur= 0s and 0kb, 
        spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x0
    Jul  4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #2
    Jul  4 14:38:08.254: IPSEC(validate_proposal_request): proposal part #2,
      (key eng. msg.) INBOUND local= 93.190.176.206, remote= 93.190.178.205, 
        local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4), 
        remote_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4),
        protocol= ESP, transform= esp-aes 256 esp-sha-hmac  (Tunnel), 
        lifedur= 0s and 0kb, 
        spi= 0x0(0), conn_id= 0, keysize= 256, flags= 0x0
    Jul  4 14:38:08.254: IPSEC(crypto_ipsec_process_proposal): invalid local address 93.190.176.206
    Jul  4 14:38:08.254: ISAKMP:(1012): IPSec policy invalidated proposal
    Jul  4 14:38:08.254: ISAKMP:(1012): phase 2 SA policy not acceptable! (local 93.190.176.206 remote 93.190.178.205)
    Jul  4 14:38:08.254: ISAKMP: set new node 680991999 to QM_IDLE      
    Jul  4 14:38:08.254: ISAKMP:(1012):Sending NOTIFY PROPOSAL_NOT_CHOSEN protocol 2
    	spi 2204243888, message ID = 680991999


    320 подключен через tp-link, потому что провайдер раздает интернет через pptp, а 320 не умеет так подключаться.

    UPD.

    Переставил crypto map с FE4 на Dialer0, мне debug выдал другую ошибку
    Jul  4 15:08:33.746: IPSEC(crypto_ipsec_process_proposal): transform proposal not supported for identity: 
        {ah-sha-hmac esp-aes 256 esp-sha-hmac }


    Тогда я поменял transform-set на то, что написано в дебаге, тоннель вроде поднялся.

    Но пинг не проходит
    Ответ написан
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    Наверное уже нет смысла показывать, ваш совет помог, все начало открываться. Спасибо еще раз!
    Ответ написан
    Комментировать
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    Лучше поздно)

    Сделал, первая ссылка - это подключение через домашний tp-link
    https://dl.dropboxusercontent.com/u/4242495/1.png

    Вторая - подключился через циско, пробую загрузить страницу. Адрес страницы другой, т.к.
    ФФ закешировал картинки и показывала как надо https://dl.dropboxusercontent.com/u/4242495/2.png

    Тут мне надоело ждать и я остановил загрузку через esc
    https://dl.dropboxusercontent.com/u/4242495/3.png

    это show process cpu sorted после остановки загрузки
    https://dl.dropboxusercontent.com/u/4242495/4.png

    это почти сразу после попытки обновить страницу
    https://dl.dropboxusercontent.com/u/4242495/5.png

    Это через несколько секунд после попытки обновления
    https://dl.dropboxusercontent.com/u/4242495/6.png
    Ответ написан
    Комментировать
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    Опять нужна ваша помощь. Все-таки что-то работает не так. И я даже не знаю как описать это. Некоторые сайты грузятся либо не с первого раза, либо грузятся частично. Заметно это на картинках. Например картинка не грузится, либо загружается только наполовину, а если пару раз обновить страницу, то она может загрузиться нормально.

    Вот скриншот. Очень показателен сайт 500px.com, там у картинок генерируется динамический адрес. Слева - браузер открытый в терминальной сессии с другого компьютера, не подключенного к настраиваемому роутеру, справа - та же страница через роутер. Провайдер один и тот же.

    кликабельно
    b531712f0bad4652830eef9972b68d38.png

    Конфиг чуть-чуть изменился (но проблема была и до внесения новых изменений), вот он:
    running-config
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service internal
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 key
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone Ukraine 2
    clock summer-time Ukraine recurring last Sun Mar 2:00 last Sun Oct 2:00
    ip subnet-zero
    no ip gratuitous-arps
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.1.1.1 10.1.1.99
    !
    ip dhcp pool LAN
    network 10.1.1.0 255.255.255.0
    dns-server 10.1.1.1
    default-router 10.1.1.1
    !
    !
    ip domain name domain.com
    ip name-server 8.8.8.8
    ip name-server 4.2.2.2
    ip name-server 208.67.222.222
    ip name-server 208.67.220.220
    ip multicast-routing
    ip ssh version 2
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip 192.168.117.249
    !
    !
    !
    !
    username user secret 5 key
    archive
    log config
    logging enable
    hidekeys
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    mac-address 0050.bfb5.b00a
    ip address dhcp client-id FastEthernet4
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface Vlan1
    ip address 10.1.1.1 255.255.255.0
    ip nat inside
    ip nat enable
    ip virtual-reassembly
    !
    interface Dialer0
    mtu 1440
    ip address negotiated
    ip pim dense-mode
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string inter.net
    dialer vpdn
    dialer-group 1
    no cdp enable
    ppp chap hostname login
    ppp chap password 0 key
    !
    ip default-gateway 10.1.1.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 192.168.0.0 255.255.0.0 FastEthernet4 dhcp
    !
    ip dns server
    !
    no ip http server
    no ip http secure-server
    ip nat inside source route-map INTERNET interface Dialer0 overload
    ip nat inside source route-map LOCAL interface FastEthernet4 overload
    !
    ip access-list standard INSIDE_NAT
    permit 10.1.1.0 0.0.0.255
    !
    dialer-list 1 protocol ip permit
    !
    route-map INTERNET permit 10
    match ip address INSIDE_NAT
    match interface Dialer0
    !
    route-map LOCAL permit 10
    match ip address INSIDE_NAT
    match interface FastEthernet4
    !
    !
    control-plane
    !
    !
    line con 0
    logging synchronous
    no modem enable
    line aux 0
    line vty 0 4
    login local
    transport input ssh
    !
    scheduler max-task-time 5000
    ntp clock-period 17179378
    ntp server 67.215.65.132
    ntp server 91.236.251.12
    end
    Ответ написан
    Комментировать
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    Ура! Заработали обе сети! =)

    Теперь по поводу DNS, вот вывод, который вы спрашивали:

    $ time dig ya.ru
    
    ; <<>> DiG 9.9.2-P1 <<>> ya.ru
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43348
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;ya.ru.				IN	A
    
    ;; ANSWER SECTION:
    ya.ru.			1077	IN	A	213.180.204.3
    ya.ru.			1077	IN	A	93.158.134.3
    ya.ru.			1077	IN	A	213.180.193.3
    
    ;; Query time: 46 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Thu Mar 13 19:13:33 2014
    ;; MSG SIZE  rcvd: 82
    
    
    real	0m1.070s
    user	0m0.004s
    sys	0m0.016s


    и
    $ time dig @8.8.8.8 ya.ru
    
    ; <<>> DiG 9.9.2-P1 <<>> @8.8.8.8 ya.ru
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27283
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;ya.ru.				IN	A
    
    ;; ANSWER SECTION:
    ya.ru.			3475	IN	A	213.180.193.3
    ya.ru.			3475	IN	A	213.180.204.3
    ya.ru.			3475	IN	A	93.158.134.3
    
    ;; Query time: 50 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Thu Mar 13 19:15:59 2014
    ;; MSG SIZE  rcvd: 82
    
    
    real	0m0.069s
    user	0m0.008s
    sys	0m0.008s
    Ответ написан
    Комментировать
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    Добавил для dialer0 ip nat outside, теперь работает интернет на компьютере и не работает внутренняя сеть.
    router#show ip nat translations 
    Pro Inside global         Inside local          Outside local         Outside global
    udp 93.190.177.42:33159   10.1.1.100:33159      208.67.220.220:53     208.67.220.220:53
    udp 93.190.177.42:34346   10.1.1.100:34346      208.67.220.220:53     208.67.220.220:53
    udp 93.190.177.42:34371   10.1.1.100:34371      208.67.222.222:53     208.67.222.222:53
    udp 93.190.177.42:35332   10.1.1.100:35332      208.67.220.220:53     208.67.220.220:53
    udp 93.190.177.42:35643   10.1.1.100:35643      208.67.222.222:53     208.67.222.222:53
    udp 93.190.177.42:35882   10.1.1.100:35882      208.67.220.220:53     208.67.220.220:53


    Правда работает как-то не так, ping domain.com долго резолвит ip для домена, хотя сайты, вроде открываются нормально.
    Вот:
    doctor@laboratory ~/Рабочий стол $ ping -Dn ya.ru
    PING ya.ru (93.158.134.3) 56(84) bytes of data.
    [1394702353.482536] 64 bytes from 93.158.134.3: icmp_req=1 ttl=57 time=36.1 ms
    [1394702354.483436] 64 bytes from 93.158.134.3: icmp_req=2 ttl=56 time=35.8 ms
    [1394702355.485298] 64 bytes from 93.158.134.3: icmp_req=3 ttl=56 time=35.7 ms
    [1394702356.487838] 64 bytes from 93.158.134.3: icmp_req=4 ttl=57 time=36.3 ms
    [1394702357.489522] 64 bytes from 93.158.134.3: icmp_req=5 ttl=56 time=36.6 ms
    [1394702358.490895] 64 bytes from 93.158.134.3: icmp_req=6 ttl=57 time=36.2 ms
    [1394702359.492631] 64 bytes from 93.158.134.3: icmp_req=7 ttl=57 time=36.5 ms
    ^C
    --- ya.ru ping statistics ---
    7 packets transmitted, 7 received, 0% packet loss, time 6009ms
    rtt min/avg/max/mdev = 35.735/36.234/36.619/0.353 ms
    doctor@laboratory ~/Рабочий стол $ ping -D ya.ru
    PING ya.ru (93.158.134.3) 56(84) bytes of data.
    [1394702373.908500] 64 bytes from www.yandex.ru (93.158.134.3): icmp_req=1 ttl=57 time=37.0 ms
    [1394702378.996749] 64 bytes from www.yandex.ru (93.158.134.3): icmp_req=2 ttl=57 time=36.0 ms
    [1394702384.081748] 64 bytes from www.yandex.ru (93.158.134.3): icmp_req=3 ttl=57 time=35.7 ms
    ^C[1394702389.168423] 64 bytes from www.yandex.ru (93.158.134.3): icmp_req=4 ttl=56 time=36.2 ms
    
    --- ya.ru ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 15261ms
    rtt min/avg/max/mdev = 35.750/36.268/37.048/0.480 ms


    В первом случае все как положено - панг раз в секунду. Во втором случае, когда имена резолвятся, пинг идет раз в 5 секунд.

    Как это исправить? И после подключения к интернету доступ во внутреннюю сеть невозможен будет?
    Ответ написан
    Комментировать
  • Что не так с настройкой pptp client на cisco 871?

    @topbanana Автор вопроса
    После попытки доступа к узлам провайдера с текущей конфигурацией
    #show ip nat translations 
    Pro Inside global         Inside local          Outside local         Outside global
    icmp 192.168.138.152:4764 10.1.1.100:4764       192.168.117.249:4764  192.168.117.249:4764


    После изменений и попытки пинга на 8.8.8.8, show ip nat translations показывает пустой вывод.

    running-config с изменениями
    Current configuration : 1908 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service internal
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 пароль
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    no ip gratuitous-arps
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.1.1.1 10.1.1.99
    !
    ip dhcp pool LAN
    network 10.1.1.0 255.255.255.0
    dns-server 10.1.1.1
    default-router 10.1.1.1
    !
    !
    ip domain name domain.com
    ip multicast-routing
    ip ssh version 2
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip 192.168.117.249
    !
    !
    !
    !
    username user secret 5 pwd
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    mac-address 0050.bfb5.b00a
    ip address dhcp client-id FastEthernet4
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface Vlan1
    ip address 10.1.1.1 255.255.255.0
    ip nat inside
    ip nat enable
    ip virtual-reassembly
    !
    interface Dialer0
    mtu 1440
    ip address negotiated
    ip pim dense-mode
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string internet
    dialer vpdn
    dialer-group 1
    no cdp enable
    ppp chap hostname login
    ppp chap password 0 pwd
    !
    ip default-gateway 10.1.1.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 192.168.0.0 255.255.0.0 FastEthernet4 dhcp
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list INSIDE_NAT interface Dialer0 overload
    !
    ip access-list standard INSIDE_NAT
    permit 10.1.1.0 0.0.0.255
    !
    dialer-list 1 protocol ip permit
    !
    !
    control-plane
    !
    !
    line con 0
    logging synchronous
    no modem enable
    line aux 0
    line vty 0 4
    login local
    transport input ssh
    !
    scheduler max-task-time 5000
    end
    Ответ написан
  • Как организовать VPN доступ к ресурсам сети?

    @topbanana
    поменяйте адресацию дома, сети дома и в офисе должны быть разными.
    Ответ написан
    3 комментария
  • Как заменить автоматом белый фон вокруг картинок на прозрачный?

    @topbanana
    Возьмите 10-15 картинок из вашей базы, откройте в графическом редакторе, и залейте белый фон контрастным цветом. В нормальных редакторах у заливки есть настройки, чтобы она белым считала не только #ffffff, но и допускала некоторые отклонения, вроде #fdfffe.

    Думаю результат вас не устроит, потому что по краям картинки все равно сохранится белая окантовка, либо заливка будет залезать на сам объект при большом допуске отклонений от белого. Особенно это заметно на тенях. Вот таким вот и будет результат автоматической замены белого на прозрачный.
    Ответ написан
    Комментировать
  • SQL запрос на поиск постов без тегов

    @topbanana
    select id from post where post.id not in (select post_id from post_tag)
    Ответ написан
    1 комментарий
  • Почему после прошивки HTC Desire S не находит wi-fi?

    @topbanana
    Вот тут у человека похожая проблема. Ему помогло изменение настроек роутера - предпоследнее сообщение.
    Ответ написан
    Комментировать
  • Обновление до 2012R2 c 2012 без потери данных

    @topbanana
    Что мешает сделать бэкап, обновиться и посмотреть что будет?
    Ответ написан
    Комментировать
  • Быстрое сообщение с веб на телефон?

    @topbanana
    Регистрируетесь, напрмер тут turbosms.ua/, и получаете возможность отправлять смс через шлюз оператора с сайта. Примеры кода там есть.
    Ответ написан
    Комментировать
  • Как избежать вложенного цикла и вообще по-человечески сделать?

    @topbanana Автор вопроса
    Всем спасибо, я понял в каком направлении думать дальше!
    Ответ написан
  • Надёжно работающий RDP-клиент под ubuntu

    @topbanana
    Обычный rdesktop. Пользуюсь уже лет 6. Все отлично. Win 2003.

    Только надо конфиг поправить для клавиатуры — заменить содержимое файлов /usr/share/rdesktop/keymaps/ru и /usr/share/rdesktop/keymaps/en-us
    вот на это:
    # generated from XKB map ru
    include common
    map 0x419
    grave 0x29
    asciitilde 0x29 shift
    asciicircum 0x07 shift
    backslash 0x2b
    bar 0x2b shift
    apostrophe 0x28
    greater 0x34 shift
    less 0x33 shift
    Ответ написан
    2 комментария
  • Программа для показа англоговорящего ТВ online

    @topbanana
    посмотрите miro, кроссплатформенный вроде.
    Ответ написан
    1 комментарий