crypto isakmp policy 1
encr 3des
authentication pre-share
lifetime 28800
crypto isakmp key preshared-key address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set MYSET esp-aes esp-sha-hmac
!
crypto dynamic-map hq-vpn 10
set security-association lifetime seconds 28800
set transform-set MYSET
match address 100
!
crypto map VPNMAP 1 ipsec-isakmp dynamic hq-vpn
!
interface FastEthernet4
crypto map VPNMAP
!
access-list 100 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
2014-07-04, 06:29:17 VPN Log [g2gips0] #442: [Tunnel Established] ISAKMP SA established
Jul 4 14:38:08.250: ISAKMP:(1012):atts are acceptable.
Jul 4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #1
Jul 4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #1,
(key eng. msg.) INBOUND local= 93.190.176.206, remote= 93.190.178.205,
local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4),
remote_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4),
protocol= AH, transform= ah-sha-hmac (Tunnel),
lifedur= 0s and 0kb,
spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x0
Jul 4 14:38:08.250: IPSEC(validate_proposal_request): proposal part #2
Jul 4 14:38:08.254: IPSEC(validate_proposal_request): proposal part #2,
(key eng. msg.) INBOUND local= 93.190.176.206, remote= 93.190.178.205,
local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4),
remote_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4),
protocol= ESP, transform= esp-aes 256 esp-sha-hmac (Tunnel),
lifedur= 0s and 0kb,
spi= 0x0(0), conn_id= 0, keysize= 256, flags= 0x0
Jul 4 14:38:08.254: IPSEC(crypto_ipsec_process_proposal): invalid local address 93.190.176.206
Jul 4 14:38:08.254: ISAKMP:(1012): IPSec policy invalidated proposal
Jul 4 14:38:08.254: ISAKMP:(1012): phase 2 SA policy not acceptable! (local 93.190.176.206 remote 93.190.178.205)
Jul 4 14:38:08.254: ISAKMP: set new node 680991999 to QM_IDLE
Jul 4 14:38:08.254: ISAKMP:(1012):Sending NOTIFY PROPOSAL_NOT_CHOSEN protocol 2
spi 2204243888, message ID = 680991999
Jul 4 15:08:33.746: IPSEC(crypto_ipsec_process_proposal): transform proposal not supported for identity:
{ah-sha-hmac esp-aes 256 esp-sha-hmac }
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname V871_router
!
boot-start-marker
boot-end-marker
!
enable secret 5 secret
!
no aaa new-model
!
resource policy
!
clock timezone Moscow 3
clock summer-time Moscow recurring last Sun Mar 2:00 last Sun Oct 2:00
ip subnet-zero
no ip gratuitous-arps
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.1.1 10.1.1.99
ip dhcp excluded-address 10.1.1.200
!
ip dhcp pool LAN
network 10.1.1.0 255.255.255.0
dns-server 10.1.1.1
default-router 10.1.1.1
!
!
ip domain name router.com
ip name-server 8.8.8.8
ip name-server 4.2.2.2
ip name-server 208.67.222.222
ip name-server 208.67.220.220
ip multicast-routing
ip ssh version 2
ip ddns update method DNSupdate
HTTP
add http://zzzzz:login@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
remove http://zzzzzzz:login@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
interval maximum 1 0 0 0
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
rotary-group 0
initiate-to ip 192.168.117.249
!
vpdn-group VPN
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
!
!
!
username user secret 5 secret
archive
log config
logging enable
hidekeys
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
lifetime 28800
crypto isakmp key my_key address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set MYSET ah-sha-hmac esp-aes 256 esp-sha-hmac
!
crypto dynamic-map hq-vpn 10
set security-association lifetime seconds 28800
set transform-set MYSET
match address 100
!
!
!
!
crypto map VPNMAP 1 ipsec-isakmp dynamic hq-vpn
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
mac-address 0015.5898.dd6a
ip address dhcp client-id FastEthernet4
ip access-group RDP in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Virtual-Template1
ip unnumbered Vlan1
peer default ip address pool VPN
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap ms-chap-v2
!
interface Vlan1
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
!
interface Dialer0
mtu 1440
ip ddns update hostname router.ddns.com
ip ddns update DNSupdate
ip address negotiated
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1400
dialer in-band
dialer idle-timeout 0
dialer string kerch.net
dialer vpdn
dialer-group 1
no cdp enable
ppp chap hostname login
ppp chap password 0 passwd
crypto map VPNMAP
!
ip local pool VPN 10.1.1.50 10.1.1.75
ip default-gateway 10.1.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.0.0 255.255.0.0 FastEthernet4 dhcp
!
ip dns server
!
no ip http server
no ip http secure-server
ip nat inside source static tcp 10.1.1.200 445 interface FastEthernet4 445
ip nat inside source static tcp 10.1.1.200 139 interface FastEthernet4 139
ip nat inside source static tcp 10.1.1.200 138 interface FastEthernet4 138
ip nat inside source static tcp 10.1.1.200 137 interface FastEthernet4 137
ip nat inside source route-map INTERNET interface Dialer0 overload
ip nat inside source route-map LOCAL interface FastEthernet4 overload
ip nat inside source static tcp 10.1.1.200 3389 interface FastEthernet4 3389
!
ip access-list standard INSIDE_NAT
permit 10.1.1.0 0.0.0.255
!
ip access-list extended RDP
permit tcp host 192.168.104.109 any eq 3389
permit tcp host 192.168.138.152 any eq 3389
permit tcp host 192.168.74.130 any eq 3389
permit tcp host 192.168.138.152 any range 137 139
permit tcp host 192.168.138.152 any eq 445
permit tcp host 192.168.74.130 any range 137 139
permit tcp host 192.168.74.130 any eq 445
deny tcp any any eq 3389 log
deny tcp any any range 137 139
deny tcp any any eq 445
permit ip any any
!
access-list 100 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
dialer-list 1 protocol ip permit
!
route-map INTERNET permit 10
match ip address INSIDE_NAT
match interface Dialer0
!
route-map LOCAL permit 10
match ip address INSIDE_NAT
match interface FastEthernet4
!
!
control-plane
!
!
line con 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
login local
transport input ssh
!
scheduler max-task-time 5000
ntp clock-period 17175059
ntp master
ntp server 67.215.65.132
ntp server 91.236.251.12
end
ip nat inside source static tcp 10.1.1.200 3389 interface FastEthernet4 3389
ip nat inside source route-map INTERNET interface Dialer0 overload
ip nat inside source route-map LOCAL interface FastEthernet4 overload
ip nat inside source static tcp 10.1.1.200 137 interface FastEthernet4 137
ip nat inside source static tcp 10.1.1.200 138 interface FastEthernet4 138
ip nat inside source static tcp 10.1.1.200 139 interface FastEthernet4 139
ip nat inside source static tcp 10.1.1.200 445 interface FastEthernet4 445
!
ip access-list extended INSIDE_NAT
deny ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
permit ip 10.1.1.0 0.0.0.255 any
ip access-list extended RDP
permit tcp host 192.168.104.109 any eq 3389
permit tcp host 192.168.138.152 any eq 3389
permit tcp host 192.168.74.130 any eq 3389
permit tcp host 192.168.138.152 any range 137 139
permit tcp host 192.168.138.152 any eq 445
permit tcp host 192.168.74.130 any range 137 139
permit tcp host 192.168.74.130 any eq 445
deny tcp any any eq 3389 log
deny tcp any any range 137 139
deny tcp any any eq 445
permit ip any any
!
access-list 100 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
dialer-list 1 protocol ip permit
!
route-map INTERNET permit 10
match ip address INSIDE_NAT
match interface Dialer0
!
route-map LOCAL permit 10
match ip address INSIDE_NAT
match interface FastEthernet4
!
#sh route-map
route-map INTERNET, permit, sequence 10
Match clauses:
ip address (access-lists): INSIDE_NAT
interface Dialer0
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map LOCAL, permit, sequence 10
Match clauses:
ip address (access-lists): INSIDE_NAT
interface FastEthernet4
Set clauses:
Policy routing matches: 0 packets, 0 bytes
#ping 10.1.2.1 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
.....
Success rate is 0 percent (0/5)
#show crypto session
Crypto session current status
Interface: Dialer0
Session status: UP-ACTIVE
Peer: 93.190.178.205 port 500
IKE SA: local 93.190.176.206/500 remote 93.190.178.205/500 Active
IPSEC FLOW: permit ip 10.1.1.0/255.255.255.0 10.1.2.0/255.255.255.0
Active SAs: 4, origin: dynamic crypto map
router(config)#no ip nat inside source route-map LOCAL interface fastEthernet 4 overload
router(config)#exit
router#ping 10.1.2.1 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
.....
Success rate is 0 percent (0/5)
2014-07-08, 21:58:02 VPN Log [g2gips0]: cmd=up-client peer=93.190.176.206 peer_client=10.1.1.0/24 peer_client_net=10.1.1.0 peer_client_mask=255.255.255.0
2014-07-08, 21:58:02 VPN Log ip route add 10.1.1.0/24 via 192.168.1.1 dev eth1 metric 35
2014-07-08, 21:58:02 VPN Log iptables -t nat -I vpn -s 10.1.2.0/24 -d 10.1.1.0/24 -j ACCEPT
2014-07-08, 21:58:02 VPN Log iptables -t nat -I vpn -s 10.1.1.0/24 -d 10.1.2.0/24 -j ACCEPT
2014-07-08, 21:58:02 VPN Log iptables -t nat -I vpn_postrouting -s 10.1.2.0/24 -d 10.1.1.0/24 -j ACCEPT
2014-07-08, 21:58:02 VPN Log iptables -t nat -I vpn_postrouting -o eth0 -s 10.1.1.0/24 -d 10.1.2.0/24 -j ACCEPT
2014-07-08, 21:58:02 VPN Log [g2gips0] #1107: [Tunnel Established] sent QI2, IPsec SA established {ESP=>0x2f20b67b < 0xcc2ebbfa AH=>0x774b729a < 0xc43b8961}
VSH_871_router#sh crypto session detail
Crypto session current status
Code: C - IKE Configuration mode, D - Dead Peer Detection
K - Keepalives, N - NAT-traversal, T - cTCP encapsulation
X - IKE Extended Authentication, F - IKE Fragmentation
Interface: Dialer0
Uptime: 00:40:37
Session status: UP-ACTIVE
Peer: 93.190.178.205 port 500 fvrf: (none) ivrf: (none)
Phase1_id: 192.168.1.100
Desc: (none)
IKE SA: local 93.190.177.103/500 remote 93.190.178.205/500 Active
Capabilities:(none) connid:2001 lifetime:07:19:22
IPSEC FLOW: permit ip 10.1.1.0/255.255.255.0 10.1.2.0/255.255.255.0
Active SAs: 4, origin: dynamic crypto map
Inbound: #pkts dec'ed 0 <b>drop 30</b> life (KB/Sec) 4500544/1162
Outbound: #pkts enc'ed 5 drop 0 life (KB/Sec) 4500549/1162
router#show crypto session detail
Crypto session current status
Code: C - IKE Configuration mode, D - Dead Peer Detection
K - Keepalives, N - NAT-traversal, T - cTCP encapsulation
X - IKE Extended Authentication, F - IKE Fragmentation
Interface: Dialer0
Uptime: 00:45:11
Session status: UP-ACTIVE
Peer: 93.190.178.205 port 500 fvrf: (none) ivrf: (none)
Phase1_id: 192.168.1.100
Desc: (none)
IKE SA: local 93.190.177.215/500 remote 93.190.178.205/500 Active
Capabilities:(none) connid:2001 lifetime:07:14:48
IPSEC FLOW: permit ip 10.1.1.0/255.255.255.0 10.1.2.0/255.255.255.0
Active SAs: 4, origin: dynamic crypto map
Inbound: #pkts dec'ed 0 drop 2701 life (KB/Sec) 4437914/888
Outbound: #pkts enc'ed 10 drop 0 life (KB/Sec) 4438378/888
Jul 16 08:00:58.303: ISAKMP (2004): received packet from 193.200.22.2 dport 500 sport 500 Global (R) QM_IDLE
Jul 16 08:00:58.303: ISAKMP: set new node -611826507 to QM_IDLE
Jul 16 08:00:58.307: ISAKMP:(2004): processing HASH payload. message ID = -611826507
Jul 16 08:00:58.307: ISAKMP:(2004): processing SA payload. message ID = -611826507
Jul 16 08:00:58.307: ISAKMP:(2004):Checking IPSec proposal 0
Jul 16 08:00:58.307: ISAKMP: transform 0, AH_SHA
Jul 16 08:00:58.307: ISAKMP: attributes in transform:
Jul 16 08:00:58.307: ISAKMP: group is 5
Jul 16 08:00:58.307: ISAKMP: encaps is 1 (Tunnel)
Jul 16 08:00:58.307: ISAKMP: SA life type in seconds
Jul 16 08:00:58.307: ISAKMP: SA life duration (basic) of 3600
Jul 16 08:00:58.307: ISAKMP: authenticator is HMAC-SHA
Jul 16 08:00:58.307: ISAKMP:(2004):atts are acceptable.
Jul 16 08:00:58.307: ISAKMP:(2004):Checking IPSec proposal 0
Jul 16 08:00:58.307: ISAKMP: transform 0, ESP_AES
Jul 16 08:00:58.307: ISAKMP: attributes in transform:
Jul 16 08:00:58.307: ISAKMP: group is 5
Jul 16 08:00:58.307: ISAKMP: encaps is 1 (Tunnel)
Jul 16 08:00:58.307: ISAKMP: SA life type in seconds
Jul 16 08:00:58.307: ISAKMP: SA life duration (basic) of 3600
Jul 16 08:00:58.307: ISAKMP: authenticator is HMAC-SHA
Jul 16 08:00:58.307: ISAKMP: key length is 256
Jul 16 08:00:58.307: ISAKMP:(2004):atts are acceptable.
Jul 16 08:00:58.307: IPSEC(validate_proposal_request): proposal part #1
Jul 16 08:00:58.307: IPSEC(validate_proposal_request): proposal part #1,
(key eng. msg.) INBOUND local= 93.190.177.215, remote= 193.200.22.2,
local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4),
remote_proxy= 192.168.1.0/255.255.255.0/0/0 (type=4),
protocol= AH, transform= NONE (Tunnel),
lifedur= 0s and 0kb,
spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x0
Jul 16 08:00:58.307: IPSEC(validate_proposal_request): proposal part #2
Jul 16 08:00:58.307: IPSEC(validate_proposal_request): proposal part #2,
(key eng. msg.) INBOUND local= 93.190.177.215, remote= 193.200.22.2,
local_proxy= 10.1.1.0/255.255.255.0/0/0 (type=4),
remote_proxy= 192.168.1.0/255.255.255.0/0/0 (type=4),
protocol= ESP, transform= NONE (Tunnel),
lifedur= 0s and 0kb,
spi= 0x0(0), conn_id= 0, keysize= 256, flags= 0x0
Jul 16 08:00:58.307: Crypto mapdb : proxy_match
src addr : 10.1.1.0
dst addr : 192.168.1.0
protocol : 0
src port : 0
dst port : 0
Jul 16 08:00:58.311: Crypto mapdb : proxy_match
src addr : 10.1.1.0
dst addr : 192.168.1.0
protocol : 0
src port : 0
dst port : 0
Jul 16 08:00:58.311: map_db_find_best did not find matching map
Jul 16 08:00:58.311: IPSEC(ipsec_process_proposal): proxy identities not supported
Jul 16 08:00:58.311: ISAKMP:(2004): IPSec policy invalidated proposal with error 32
Jul 16 08:00:58.311: ISAKMP:(2004): phase 2 SA policy not acceptable! (local 93.190.177.215 remote 193.200.22.2)
Jul 16 08:00:58.311: ISAKMP: set new node 277978537 to QM_IDLE
Jul 16 08:00:58.311: ISAKMP:(2004):Sending NOTIFY PROPOSAL_NOT_CHOSEN protocol 2
spi 2223674800, message ID = 277978537
Jul 16 08:00:58.311: ISAKMP:(2004): sending packet to 193.200.22.2 my_port 500 peer_port 500 (R) QM_IDLE
Jul 16 08:00:58.311: ISAKMP:(2004):Sending an IKE IPv4 Packet.
Jul 16 08:00:58.311: ISAKMP:(2004):purging node 277978537
Jul 16 08:00:58.311: ISAKMP:(2004):deleting node -611826507 error TRUE reason "QM rejected"
Jul 16 08:00:58.311: ISAKMP:(2004):Node -611826507, Input = IKE_MESG_FROM_PEER, IKE_QM_EXCH
Jul 16 08:00:58.311: ISAKMP:(2004):Old State = IKE_QM_READY New State = IKE_QM_READY
Jul 16 08:00:59.455: ISAKMP:(2003):purging node 2045592847
Jul 16 08:01:04.348: ISAKMP (0): received packet from 193.200.22.2 dport 500 sport 500 Global (N) NEW SA
Jul 16 08:01:04.348: %CRYPTO-4-IKMP_NO_SA: IKE message from 193.200.22.2 has no SA and is not an initialization offer
Jul 16 08:01:08.357: ISAKMP (2004): received packet from 193.200.22.2 dport 500 sport 500 Global (R) QM_IDLE
Jul 16 08:01:08.357: ISAKMP:(2004): phase 2 packet is a duplicate of a previous packet.
Jul 16 08:01:08.357: ISAKMP:(2004): retransmitting due to retransmit phase 2
Jul 16 08:01:08.357: ISAKMP:(2004): ignoring retransmission,because phase2 node marked dead -611826507
Jul 16 08:01:08.357: ISAKMP (2003): received packet from 193.200.22.2 dport 500 sport 500 Global (R) MM_NO_STATE