@alexustdv_ru

Почему не устанавливается веб окружение для Битрикс24 на Linux CentOS?

[root@echocrm ~]# ./bitrix-env.sh
System update in progress. Please wait.
Error updating the system.

Лог:
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package mariadb-libs.x86_64 1:5.5.68-1.el7 will be obsoleted
--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-5.5.68-1.el7.x86_64
--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-server-5.5.68-1.el7.x86_64
---> Package php-mysql.x86_64 0:5.4.45-17.el7.remi will be an update
--> Processing Dependency: php-mysql for package: ispmanager-pkg-roundcube-5.282.2-1.el7.x86_64
--> Running transaction check
---> Package mariadb-libs.x86_64 1:5.5.68-1.el7 will be obsoleted
--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-5.5.68-1.el7.x86_64
--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-server-5.5.68-1.el7.x86_64
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.17.20160812git230a828.el7.remi.7.2 will be installed
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.45-17.el7.remi.x86_64 (remi)
Requires: php-pdo(x86-64) = 5.4.45-17.el7.remi
Removing: php-pdo-5.4.16-48.el7.x86_64 (@base)
php-pdo(x86-64) = 5.4.16-48.el7
Updated By: php-pdo-7.2.34-3.el7.remi.x86_64 (remi-php72)
php-pdo(x86-64) = 7.2.34-3.el7.remi
Available: php-pdo-5.4.45-18.el7.remi.x86_64 (remi)
php-pdo(x86-64) = 5.4.45-18.el7.remi
Available: php-pdo-7.2.34-2.el7.remi.x86_64 (remi-php72)
php-pdo(x86-64) = 7.2.34-2.el7.remi
Error: Package: php-mysql-5.4.45-18.el7.remi.x86_64 (remi)
Requires: php-pdo(x86-64) = 5.4.45-18.el7.remi
Removing: php-pdo-5.4.16-48.el7.x86_64 (@base)
php-pdo(x86-64) = 5.4.16-48.el7
Updated By: php-pdo-7.2.34-3.el7.remi.x86_64 (remi-php72)
php-pdo(x86-64) = 7.2.34-3.el7.remi
Available: php-pdo-5.4.45-18.el7.remi.x86_64 (remi)
php-pdo(x86-64) = 5.4.45-18.el7.remi
Available: php-pdo-7.2.34-2.el7.remi.x86_64 (remi-php72)
php-pdo(x86-64) = 7.2.34-2.el7.remi
Error: php-mysql conflicts with php-mysqlnd-7.2.34-3.el7.remi.x86_64
Error: Package: 1:mariadb-5.5.68-1.el7.x86_64 (@base)
Requires: mariadb-libs(x86-64) = 1:5.5.68-1.el7
Removing: 1:mariadb-libs-5.5.68-1.el7.x86_64 (@base)
mariadb-libs(x86-64) = 1:5.5.68-1.el7
Obsoleted By: Percona-Server-shared-compat-57-5.7.32-35.1.el7.x86_64 (percona-release-x86_64)
Not found
Error: Package: 1:mariadb-server-5.5.68-1.el7.x86_64 (@base)
Requires: mariadb-libs(x86-64) = 1:5.5.68-1.el7
Removing: 1:mariadb-libs-5.5.68-1.el7.x86_64 (@base)
mariadb-libs(x86-64) = 1:5.5.68-1.el7
Obsoleted By: Percona-Server-shared-compat-57-5.7.32-35.1.el7.x86_64 (percona-release-x86_64)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
2021-02-09T11:07:30: 3226 : Error updating the system.
2021-02-09T11:07:30: 3226 : Log file path: /tmp/bitrix-env-0Ll7O.log
  • Вопрос задан
  • 55 просмотров
Пригласить эксперта
Ответы на вопрос 1
gromdron
@gromdron Куратор тега Битрикс24
Bitrix developer
Удалите пакеты mariadb*, они мешают установиться Percona-Server
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы