@MrDZ

L2TP + ipsec между mikrotik, как настроить маршрутизацию?

Всём привет, подскажите как правильно настроить маршрутизацию между 172.16.0.1 и 192.168.2.1 в следующей схеме:

Сейчас есть:
5fe6085a63e3c317548923.jpeg

Офис (172.16.0.0/24) и удаленный объект (192.168.1.0/24) имеют между собой туннель ipsec. На корневом коммутаторе присутствуют статические маршруты до сети 192.168.1.0/24. Корневой коммутатор и маршрутизатор 172.16.0.1 входят в зону OSPF.
Решил установить ещё L2TP server на 172.16.0.1. Маршрутизатор в офисе и в удаленном объекте друг друга пингуют. А хосты за маршрутизаторами друг друга не видят.

Задача: правильно настроить маршрутизацию.

Что было сделано:

Выделил pool адресов на vpn 10.0.0.0/24, на server L2TP назначил адрес 10.0.0.1, клиенты получают адреса из pool.
Добавил статический маршрут на корневой коммутатор до 192.168.2.0/24

Настройка маршрутизатора Mikrotik в центральном офисе:

/ip pool add name=vpn_pool ranges=10.0.0.2-10.0.0.254
/ppp profile add local-address=10.0.0.1 name=L2TP remote-address=vpn_pool
/ppp secret add name=192.168.2.1 password=pass profile=L2TP service=l2tp
/interface l2tp-server server set default-profile=L2TP enabled=yes ipsec-secret=pass use-ipsec=required
/ip route add distance=200 dst-address=192.168.2.0/24 gateway=l2tp-192.168.2.1

Настройки клиента:

/interface l2tp-client add allow=mschap2 connect-to=8.254.254.8 disabled=no ipsec-secret=pass name=ru password=pass use-ipsec=yes user=remoteuser
/ip route add distance=200 dst-address=172.16.1.0/24 gateway=ru


Из сети центрального офиса (172.16.1.0/24) по адресу из vpn_pool удаленный маршрутизатор по ip доступен.

PS. Пробовал убирать ipsec, из центрального офиса пингуются хосты, обратно нет.
  • Вопрос задан
  • 95 просмотров
Решения вопроса 1
@nApoBo3
NAT?
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы