@torns
Пишу код в удовольсвие

Как решить ошибку Composer?

Всем привет, разжуйте мне пожалуйста что не так.
Подтягиваю пакет в Laravel 8.3
composer require rorecek/laravel-ulid:^2.0

Информирует о проблеме, как я понял просят поставить Laravel 5.3.7, хотя в composer.json этого пакета есть отметка о 8-й версии ларавеля.

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for rorecek/laravel-ulid 2.0 -> satisfiable by rorecek/laravel-ulid[v2.0.0].
    - Installation request for laravel/framework (locked at v8.3.0, required as ^8.3) -> satisfiable by laravel/framework[v8.3.0].
    - Can only install one of: laravel/framework[8.x-dev, 5.7.x-dev].
    - Can only install one of: laravel/framework[v8.3.0, 5.7.x-dev].
    - Can only install one of: laravel/framework[5.7.x-dev, v8.3.0].
    - Can only install one of: laravel/framework[5.7.x-dev, v8.3.0].
    - Conclusion: install laravel/framework 5.7.x-dev
    - Installation request for laravel/framework ^8.3 -> satisfiable by laravel/framework[8.x-dev, v8.3.0].
  • Вопрос задан
  • 40 просмотров
Решения вопроса 1
@torns Автор вопроса
Пишу код в удовольсвие
composer require rorecek/laravel-ulid:~2.0
~ вместо ^
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы