@Spleen0989

Почему не запускается бот?

Здравствуйте. Запускаю бота на vds, (ubuntu 18.04+docker), выдает вот такую ошибку:
docker run -ti -e PYTHONIOENCODING=utf-8 chatbotа
Using TensorFlow backend.
./console_bot.sh: line 3: 6 Illegal instruction (core dumped) PYTHONPATH=.. python3 ../ruchatbot/frontend/console_chatbot.py --profile ../data/profile_1.json --data_folder ../data --models_folder ../tmp --w2v_folder ../tmp --tmp_folder ../tmp

Что нужно доустановить, дописать или настроить? Что я делаю не так? От чистого седрца заранее благодарю за конструктивные, развернутые ответы.
  • Вопрос задан
  • 182 просмотра
Пригласить эксперта
Ответы на вопрос 2
@nubrik
Скорее всего версия TensorFlow не совместима с опартным обеспечением компьютера. Я рекомендовал бы сменить "RUN pip install tensorflow==1.14" на "RUN pip install tensorflow" и дать возможность pip самому выбрать подходящую версию tensorflow, если нет привязки к ее версии
Ответ написан
Комментировать
@Spleen0989 Автор вопроса
тут походу старье. пайтон 3.6 и все такое... что если 16.04 и docker накатить?
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы