Как сделать счетчик расстояния между числами в Excel?

Как одной формулой считать расстояние от одного числа к другому, автоматически определяя число или пустую ячейку?
spoiler
5f149dcf38035996190643.jpeg

Я использовал такую формулу =СЧИТАТЬПУСТОТЫ. Это работает, но с одним диапазоном выставленным вручную.
Можно ли сделать что бы в диапазоне (А2:А1001) находило числа и расстояние между ними. А расстояние между каждым числом выводило в отдельную ячейку, а потом каждое расстояние с помощью =СРЗНАЧ узнать среднее значение. Или это сделать макросом?
  • Вопрос задан
  • 144 просмотра
Решения вопроса 1
ProgrammerForever
@ProgrammerForever
Учитель, автоэлектрик, программист, музыкант
1) Создаем столбец с признаком того что в первом столбце есть текст
=ЕСЛИ(A1="";"";"!")
2) Ищем номер очередной строки в которой есть "!"
Для первой строки:
=ПОИСКПОЗ("!";B1:B1000;0)
Для последующих:
=ПОИСКПОЗ("!";ДВССЫЛ("R"&(C1+1)&"C[-1]:R10000C[-1]";0);0)+C1

3) Вычисляем расстояние
=C2-C1-1
4) Вычисляем среднее
=СРЗНАЧ(D1:D1000)

Всё это можно посмотреть в демонстрационной таблице
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы