@Serg436

Возможно ли перенести функции Cisco 2621 на Cisco 2911?

Вопрос в следующем, существует такая вот структура сети:
5ea40fde9051a463978964.jpeg
Вышел из строя роутер 2621. На нем было 2 порта FastEthernet, один из которых шел в ADSL модем, второй в маршрутизатор 3560 на котором подняты Vlanы. конфиг 2621 :
isdn switch-type basic-net3
isdn leased-line BRI0/0
!
!
!
username 
!
!
class-map match-all VoiceInput
 match access-group 10
class-map match-any real-time
 match ip precedence 5 
 match ip dscp cs5 
 match ip dscp ef 
class-map match-all voice-traffic
 match ip dscp ef 
!
!
policy-map qos-stat
  class real-time
  class class-default
policy-map MarkVoice
  description ### Voice marking ###
  class VoiceInput
  set ip precedence 5
policy-map VOICE-POLICY
  class voice-traffic
  priority 64
  class class-default
  fair-queue
!
! 
!
!
!
interface Loopback0
 ip address 10.23.4.50 255.255.255.240
 ip virtual-reassembly
!
interface FastEthernet0/0
 description TO_MPLS
 ip address 10.23.255.14 255.255.255.252
 ip flow ingress
 ip flow egress
 no ip route-cache cef
 no ip mroute-cache
 duplex auto
 speed auto
 service-policy input qos-stat
!
interface BRI0/0
 no ip address
 shutdown
!
interface BRI0/0:1
 no ip address
!
interface BRI0/0:2
 no ip address
!
interface FastEthernet0/1
 description TO_PBX_HG_1500
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 description TO_CONTINENT
 encapsulation dot1Q 5 native
 ip address 10.23.4.1 255.255.255.248
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
interface FastEthernet0/1.2
 description TO_HIPATH
 encapsulation dot1Q 2
 ip address 10.33.4.1 255.255.255.0
 no snmp trap link-status
 service-policy input MarkVoice
!
interface FastEthernet0/1.10
 ip flow ingress
 ip flow egress
!
interface Group-Async1
 physical-layer async
 ip unnumbered Loopback0
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 ppp authentication chap pap
!
ip local pool default 10.23.4.17 10.23.4.25
ip classless
ip route 0.0.0.0 0.0.0.0 10.23.255.13
ip route 192.168.4.0 255.255.255.0 10.23.4.2
!
ip flow-export source FastEthernet0/1.1
ip flow-export version 5
ip flow-export destination 10.33.0.70 2055
!
ip http server
no ip http secure-server
ip nat inside source static 10.23.4.2 217.147.2.69
!
logging source-interface FastEthernet0/1.1
logging 10.10.23.59
logging 10.33.0.70
access-list 10 permit 10.33.0.0 0.0.255.255
snmp-server community 
snmp-server enable traps tty
snmp-server enable traps envmon
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server host 10.33.0.80
!
!
control-plane
isdn switch-type basic-net3
isdn leased-line BRI0/0
!
!
!
username adm secret 5 $1$ZB7N$B.M.yp2A3EvHPhx5NQBu8.
!
!
class-map match-all VoiceInput
 match access-group 10
class-map match-any real-time
 match ip precedence 5 
 match ip dscp cs5 
 match ip dscp ef 
class-map match-all voice-traffic
 match ip dscp ef 
!
!
policy-map qos-stat
  class real-time
  class class-default
policy-map MarkVoice
  description ### Voice marking ###
  class VoiceInput
  set ip precedence 5
policy-map VOICE-POLICY
  class voice-traffic
  priority 64
  class class-default
  fair-queue
!
interface Loopback0
 ip address 10.23.4.50 255.255.255.240
 ip virtual-reassembly
!
interface FastEthernet0/0
 description TO_MPLS
 ip address 10.23.255.14 255.255.255.252
 ip flow ingress
 ip flow egress
 no ip route-cache cef
 no ip mroute-cache
 duplex auto
 speed auto
 service-policy input qos-stat
!
interface BRI0/0
 no ip address
 shutdown
!
interface BRI0/0:1
 no ip address
!
interface BRI0/0:2
 no ip address
!
interface FastEthernet0/1
 description TO_PBX_HG_1500
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 description TO_CONTINENT
 encapsulation dot1Q 5 native
 ip address 10.23.4.1 255.255.255.248
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!
interface FastEthernet0/1.2
 description TO_HIPATH
 encapsulation dot1Q 2
 ip address 10.33.4.1 255.255.255.0
 no snmp trap link-status
 service-policy input MarkVoice
!
interface FastEthernet0/1.10
 ip flow ingress
 ip flow egress
!
interface Group-Async1
 physical-layer async
 ip unnumbered Loopback0
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 ppp authentication chap pap
!
ip local pool default 10.23.4.17 10.23.4.25
ip classless
ip route 0.0.0.0 0.0.0.0 10.23.255.13
ip route 192.168.4.0 255.255.255.0 10.23.4.2
!
ip flow-export source FastEthernet0/1.1
ip flow-export version 5
ip flow-export destination 10.33.0.70 2055
!
ip http server
no ip http secure-server
ip nat inside source static 10.23.4.2 217.147.2.69
!
logging source-interface FastEthernet0/1.1
logging 10.10.23.59
logging 10.33.0.70
access-list 10 permit 10.33.0.0 0.0.255.255
snmp-server community swmgm2361 RO
snmp-server enable traps tty
snmp-server enable traps envmon
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server host 10.33.0.80 version 2c swmgm2361 
!
!
control-plane

Возможно ли пренести его функции на CISCO 2911, на ней имеется два свободных GigabitEthernet порта
конфиг 2911:
adm
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 
!
boot-start-marker
boot system flash:c2900-universalk9_npe-mz.SPA.152-1.T.bin
boot-end-marker
!
enable secret 
!
aaa new-model
!
aaa authentication login default local
aaa authorization exec default local 
!
aaa session-id common
clock timezone MSK 4 0
!
no ipv6 cef
!
ip cef
multilink bundle-name authenticated
!
trunk group 1
 hunt-scheme round-robin
!
crypto pki token default removal timeout 0
!
voice-card 0
!
voice service voip
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol pass-through 
 modem passthrough nse
!
voice class dualtone-detect-params 1
 freq-max-deviation 50
 cadence-variation 5
!
voice class custom-cptone class1
 dualtone disconnect
  frequency 425
  cadence 350 350
!
application
global
service alternate Default

!
license udi pid CISCO2911/K9 sn 
hw-module pvdm 0/0
!
username adm secret 
!
redundancy
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.33.4.4 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.33.4.1
!
ip sla responder
ip sla 40000
 udp-jitter 10.33.1.4 10000 source-ip 10.33.4.4 
 tos 184
 owner 
 frequency 300

И если возможно то как ? Пытался настроить один из gigabyte портов, включал его, но данные не идут не могу пропинговать шлюз за adsl модемом, модем в режиме bridge работает.
  • Вопрос задан
  • 101 просмотр
Пригласить эксперта
Ответы на вопрос 1
anthtml
@anthtml
Системный администратор программист радиолюбитель
Из вопроса не совсем понятно - Вам нужно полностью заменить 26хх на 29хх или добавить к существующим функциям 29хх функции умершего 26хх? И что выполняют железки, чисто VOIP или еще и интернет маршрутят?
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы