akelsey
@akelsey

Публичные адреса на Proxmox через бридж, почему может вылетать через опред. время?

Нужна помощь сообщества, сконифигурен ProxMox на Debian 10, куплены порядка 20 публичных адресов, все они были по умолчанию привязаны на eth0, ниже как это было сконфигурено по дефолту, привожу пример с 1 адресом:

# The loopback network interface

auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static
        address xx.yyy.162.143/23
        gateway xx.yyy.162.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 1.1.1.1
        dns-search mydomain.com
        
auto eth0:1
allow-hotplug eth0:1
iface eth0:1 inet static
  address xx.yyy.163.84
  netmask 255.255.255.255


После я переконфигурил таким образом (кол-во бриджей равно кол-ву публичных адресов, в примере опять же только один):

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static
        address xx.yyy.162.143/23
        gateway xx.yyy.162.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 1.1.1.1
        dns-search mydomain.com

auto vmbr1084
iface vmbr1084  inet static
 address xx.yyy.162.143
 netmask 255.255.254.0
 bridge-ports none
 bridge-stp off
 bridge-fd 0
 bridge_maxwait 0
 up ip route add xx.yyy.163.84/32 dev vmbr1084
 down ip route delete xx.yyy.163.84/32 dev vmbr1084
#Ext-84 [xx.yyy.163.84]


Внутри виртуальной машины настраивается так, в примере Windows Server (используется point-to-point link):

IP: xx.yyy.163.84
NET: 255.255.255.255
GW: xx.yyy.162.143


Всё работает прекрасно, но не долго, иногда 1 час, иногда 4 часа, логов не густо, возможно я не знаю где искать, конфигурация в целом не меняется.
Симптомы - просто все перестает работать, изнутри ВМ пропадает доступ куда угодно, снаружи тоже.
При этом изнутри я вижу arp request/arp reply, а вот с хостовой машины arp request есть, а arp replay не возвращается, в арп кэше вроде все ок.
Не понимаю даже в какую сторону копнуть.
При сбросе сетевых интерфейсов - всё опять начинает работать, но снова рандомное кол-во времени.
Буду признателен любым советам.

uname -a
Linux myhostname 5.3.18-3-pve #1 SMP PVE 5.3.18-3 (Tue, 17 Mar 2020 16:33:19 +0100) x86_64 GNU/Linux
  • Вопрос задан
  • 105 просмотров
Решения вопроса 1
Sanes
@Sanes
!
На хосте не надо добавлять доп. адреса, если это не host-routed. Достаточно настроить на гостевой.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
fara_ib
@fara_ib
Может попробовать добавить еще одну виртуалочку например с pfsense и ее использовать как шлюз, так и безопасней и снорт там есть ну типа защита от враждебного инета и главное там есть мульти ван у меня в ответах была инструкция как конкретный белый ip (из нескольких) пробросить в сеть за натом ну к другим виртуалкам.
Ответ написан
opium
@opium
Просто люблю качественно работать
Syslog посмотрите и дмесг
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы