antoo
@antoo

Mikrotik: как настроить маршрут для одного из адресов, прилетевшего по BGP?

У меня мало опыта в настройках Mikrotik, пытаюсь настроить обход блокировок согласно статье: https://habr.com/post/413049/.
VPN-туннель уже работает и протестирован, но существует следующая проблема: в прилетающих по BGP данных содержится диапазон, в котором находится IP моего VPN-сервера (хотя он не заблокирован, но почему-то там есть), в результате чего маршрут видимо зацикливается и VPN на роутере перестает работать вообще.

Я планирую решить данную проблему, создав статический маршрут который будет отправлять пакеты на IP-адрес VPNа в WAN. Пробовал решить проблему в лоб (ether1 - WAN, 1.2.3.4 - IP сервера VPN):
/ip route add dst-address=1.2.3.4 gateway=ether1, после этого VPN сразу же перестает работать, даже при выключенном BGP.

Вопросы следующие:
1) Почему правило ломает VPN?
2) Можно ли вообще решить эту проблему через подобный статический маршрут, и как в таком случае будут настраиваться приоритеты таких маршрутов над теми, что прилетают по BGP?
3) Если мой вариант неправильный, расскажите, пожалуйста, как решить эту проблему правильно?

Большое спасибо!

---
UPD: Также попытался сделать через mangle - соединение с VPN не пропадает до того, как включаются правила с BGP, далее опять все отваливается:
/ip route add dst-address=0.0.0.0/0 gateway=ether1 routing-mark=DIRECT-mark
/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade
/ip firewall mangle add chain=prerouting dst-address-list=DIRECT action=mark-routing new-routing-mark=DIRECT-mark
/ip firewall address-list add list=DIRECT address=1.2.3.4
  • Вопрос задан
  • 2862 просмотра
Решения вопроса 1
poisons
@poisons
/routing filter должен помочь.
3) Подход кривой. В любом случае огромное спасибо автору исходной статьи, но это из серии "смотрите как я могу".
В блокировку уходят подсети пачками, вам точно нужны все эти маршруты на роутере? На микроте уже давно существует возможность запихнуть в адрес лист доменное имя, в mangle навешивайте routing mark и заворачивайте в туннель.

П.С.
gateway=ether1 - вот тут должен быть гейтвей.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы