programmist_derevo
@programmist_derevo

Какие Android API стоит включать в приложение? Стоит ли включать все?

При компиляции приложения или игры дается выбор минимального поддерживаемого API и целевого. Стоит ли мне включать сюда весь список API от минимального до самого последнего? Или достаточно просто включить один минимальный да и всё, например у меня минимальный будет для 4.4 КитКата. Если на киткате всё заведется, то на поздних Андроидах тоже будет работать или обязательно надо прям все API включать?

Просто хочу сэкономить размер итогового приложения.
  • Вопрос задан
  • 1756 просмотров
Решения вопроса 2
samodum
@samodum
Какой вопрос - такой и ответ
Не совсем понятно, при чём здесь список API.
Нужно просто указать minSdkVersion. Принято, что minSdkVersion должна быть хотя бы 17. Та же Android Studio на этапе создания проекта показывает количество поддерживаемых устройств в процентах, либо берите это с официального сайта https://developer.android.com/about/dashboards/
Далее, вы должны исследовать, какие фичи андроида из более новых версий вам понадобятся (кастомизация уведомлений, например, которые в более ранних версиях не поддерживаются), а также учтите, что некоторые подключаемые библиотеки потребуют определённые версии Android Sdk.
Взвесив все "за" и "против" выставляете свой minSdkVersion и наслаждаетесь потом отзывами юзеров в духе "А на моём андроиде 4.2 это не работает", "у меня сони, андроид 6.0 и прога вылетает..."
То, что заводится на одном 4.4 не всегда будет работать на другом точно таком же андроиде, но от другого производителя. Разные производители делают свои глючные оболочки...
Ответ написан
zagayevskiy
@zagayevskiy Куратор тега Android
Android developer at Yandex
Про минимальный апи тебе всё верно сказали - нужно выбирать, какой ты поддерживаешь. На более старых просто нельзя будет поставить приложение.
Теперь про таргет (это важно) https://developer.android.com/distribute/best-prac...
"Google Play will require that new apps target at least Android 8.0 (API level 26) from August 1, 2018, and that app updates target Android 8.0 from November 1, 2018"
Что это значит для тебя? Это значит, что кроме возможности использовать фичи новых андроидов, у тебя появляется обязанность поддерживать их ограничения. Например, ограничения на запуск сервисов в фоне, рантайм пермишины и тд.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@Doc44
У новых API могут быть нужные вам возможности.
Если эти возможности не нужны - то не включайте.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы