Как получить адрес паблика с интерфейсов, на которых есть ещё несколько приватных сетей на MikroTik?

есть цель сделать скрипт, который бы настраивал автоматом firewall filter для офиса.
на mikrotik настраивается на одном из портов паблик (/30), на этом же интерфейсе и на соседних могут быть адреса из 10.0.0.0/8, 192.168.0.0/16, 172.0.0.0/8.
Соответственно хочется чтоб появлялось при выполнении скрипта три файрвольных правила - разрешить порт 1701 udp и icmp на паблик, который висит на нашем микроте (из /30 ) и запретить весь остальной трафик на input чейне.

проблема в том, что не могу выгрести этот самый айпишник /30 среди всех частных айпишников.

ps: угадать на какой интерфейс повесят паблик невозможно, как рука местного инженера ляжет. не я это придумал, вот такой вот дизайн исторически сложился.
  • Вопрос задан
  • 240 просмотров
Пригласить эксперта
Ответы на вопрос 2
FarSeerMellon
@FarSeerMellon
Пионер
/ip firewall address-list
add address=10.0.0.0/8 list=white_list
add address=192.168.0.0/16 list=white_list
add address=172.0.0.0/8 list=white_list
/ip firewall filter
add action=drop chain=input src-address-list=!white_list
Если я правильно понял ТС, то так.
Ответ написан
Может такой костыль подойдет)
/tool fetch url="myip.dnsomatic.com" mode=http dst-path=publicip.txt
:global ip [/file get publicip.txt contents]
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы