KVM, подсети Hetzner и роутинг

Дано:
— Сервер роутинг, на котором работает KVM и 4 виртуалки под ним.
— 2 подсети /29 (по 6 IP в каждой, соответственно).

В данный момент 4 виртуалки работают в первой подсети.
Настроено все просто:
При загрузке запускается скриптик, который делает следующее:
brctl addbr br0
ifconfig br0 176.9.ххх.62 netmask 255.255.255.248 up
route add -host 176.9.ххх.58 dev br0
route add -host 176.9.ххх.59 dev br0
route add -host 176.9.ххх.60 dev br0
route add -host 176.9.ххх.61 dev br0

В виртуалках настройки адаптера — bridged на br0. Внутри настройки ip 176.9.ххх.58 mask 255.255.255.248 gw 176.9.ххх.62. Настраивалось примерно вот по этому гайду: wiki.hetzner.de/index.php/KVM (господи, благослави Google Translate).
Все работает отлично.

Сейчас появилась необходимость добавить еще 3-4 виртуалки, поэтому была куплена новая подсеть 176.9.ххх.200 /29
Казалось бы, алгоритм следующий: Добавить новый br1 (с IP 176.9.xxx.206), затем сделать route'ы от IP 176.9.ххх.200 — 176.9.ххх.205 к br1, при создании виртуалок указывать bridge interface — br1.
Вроде все так, но… Не работает. При задании таких настроек в гостевой ОС eth0 не поднимается. При установке ОС пишет «Не возможно применить данные настройки», если попробовать задать настройки в уже установленной ОС, то после перезагрузки сеть сама не поднимается на ifup eth0 выдает загадочное «Failed to bring up eth0».
При этом, 176.9.xxx.206 (шлюз br1) извне вполне себе пигнуется.

В чем может быть проблема?
  • Вопрос задан
  • 5854 просмотра
Пригласить эксперта
Ответы на вопрос 1
@inkvizitor68sl
Linux-сисадмин с 8 летним стажем.
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы