@Cryopsy
системный администратор, вокалист

Корректно ли я настроил сетевой интерфейс в ubuntu?

Добрый день, подскажите пожалуйста есть ВМ с 2 интерфейсами у хостинг провайдера. На eth0 выход в интернет и белый адрес, а на eth1 серая подсеть уходящая со стороны хостинга в туннель. Интересует именно интерфейс eth1.
В interfaces eth1 имеет следующие настройки:
auto eth1
iface eth1 inet static
  address 10.10.200.5
  netmask 255.255.255.252

Далее приведу параметры сети:
Network: 10.10.200.3/30
Address: 10.10.200.5
Gateway: 10.10.200.4

Добавился маршрут:
10.10.200.3/30 dev eth1 proto kernel scope link src 10.10.200.5

Но при этом шлюз не пингуется.
Корректны ли настройки моего интерфейса? (при условии если пинг на шлюзе разрешен)
  • Вопрос задан
  • 168 просмотров
Решения вопроса 1
dyuriev
@dyuriev
A posteriori
Вот тут у вас ошибка
Network: 10.10.200.3/30


измените везде на 10.10.200.4/30 тогда это будет подсеть 10.10.200.4-10.0.200.7
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 3
ky0
@ky0
Миллиардер, филантроп, патологический лгун
Попробуйте так:
ip route add 10.10.200.3/30 dev eth1 via 10.10.200.4
Ответ написан
@fbi_suck
Эникей
10.10.200.3 при маске 30 это широковещательный адрес , а не адрес сети, соответственно адреса 10.10.200.4 и .5 не входят в эту сеть. Сеть тут наверное 10.10.200.4/30 с адресами устройств .5 и .6 и широковещательным .7
Ну и раз у вас адрес .5 , то шлюз наверное .6
Ответ написан
Комментировать
CityCat4
@CityCat4
//COPY01 EXEC PGM=IEBGENER
Network: 10.10.200.3/30

Не бывает. Либо 10.10.200.0/30, либо 10.10.200.4/30. Исходя из приведенных адресов, шлюз - 10.10.200.6
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы