@aldus551
фрилансер

Какой Линукс подойдет для этого компьютера?

Наткнулся на старый системный блок Fujitsu Siemens Scenic Pentium 4 с 1.5 Гб памяти. Вполне работоспособен, на нем стояла Семерка и Восьмерка от Мелкомягких. Правда, 32-х битные.Хочу запустить на нем Линукс, но не знаю какой дистрибутив подойдет под такого старичка. Можно ли будет подыскать под него что-нибудь стоящее?
  • Вопрос задан
  • 258 просмотров
Пригласить эксперта
Ответы на вопрос 5
Adamos
@Adamos
Главный вопрос - стоящее ЧЕГО. Запустить на этом Линь с легким DE и офисом получится - будет весьма неторопливо, но многие пользователи сами медленнее даже такой машинки.
Можно ускорить отзывчивость, поставив современный этому железу дистрибутив и программы, еще не отожравшиеся по памяти.
Но вы же, подозреваю, захотите интернету? А значит, современный браузер, который сожрет всю эту память прямо при старте и будет постоянно хотеть еще, терзая своп...
Ответ написан
ValdikSS
@ValdikSS
У вас 32-битный процессор? Из современных именитых x86 32-битных дистрибутивов осталось только два: Debian и OpenSUSE Tumbleweed. Остальные либо еще формируют 32-битные пакеты, но не выпускают установочные .iso (а значит, никто эти пакеты не проверяет), либо вовсе не собирают x86, либо многие пакеты в них сломаны, как в ArchLinux32.

Рекомендую вам попробовать с Debian 12 (bookworm, в данный момент в testing), т.к. он достаточно свежий, а главное — в нём свежее ядро, в котором решена давняя проблема Linux — зависание при недостатке памяти.
После установки, выполните следующие команды, чтобы увеличить отзывчивость:

sudo apt install zram-tools
sudo sed -i 's/^#PERCENT=.*/PERCENT=150/' /etc/default/zramswap
echo 'w-      /sys/kernel/mm/lru_gen/enabled          -       -       -       -       y' | sudo tee /etc/tmpfiles.d/mglru.conf
echo 'w-      /sys/kernel/mm/lru_gen/min_ttl_ms       -       -       -       -       1000' | sudo tee -a /etc/tmpfiles.d/mglru.conf


Перезагрузитесь, затем пробуйте пользоваться системой.

Если же у вас Pentium 4 из более поздних поколений, то можете установить 64-битный дистрибутив, из выбор значительно шире. См. статью по ссылке выше.
Ответ написан
Комментировать
shambler81
@shambler81 Куратор тега Linux
Thinstation это пожалуй единственное тчо на нем пойдет для полноценной работы
Загрузка по pxe +Thinstation и получаеш виндовс 10 с полноценной производительностью
На все остальное маловато.
Так чисто побаловатся то без разницы, консоль тоже.
А вот если десктоп то
Ответ написан
Комментировать
@nihi1ist
Debian с Openbox + tint2 + Pale Moon например. Но это только вручную пакеты ставить, чтобы куча зависимостей не подтянулась.
Ответ написан
Комментировать
@rPman
какая именно модель? а то пентиумы разные были
Процессоры Pentium 4 на ядре Prescott получили поддержку нового дополнительного набора команд — SSE3, а также поддержку технологии EM64T (в ранних процессорах поддержка 64-битных расширений была отключена). Кроме того, была оптимизирована технология Hyper-threading (в частности, в набор SSE3 вошли инструкции, предназначенные для синхронизации потоков)

собственно этот момент определит, будет ли принципиальная возможность запуска последних версий готовых debian/redhat или придется собирать gentoo/linux from scratch (между прочим лучший способ собрать ОС под ограниченные задачи и чтобы современный код был)

Если поддержки нет, то можно подобрать нужную версию 32-bit дистрибутива той же ubuntu (настоятельно рекомендую выбирать xubuntu/lubuntu/edubuntu с легковестными DE, можно вручную поставить какой-нибудь openbox или даже awesome.

Самая большая проблема, после невероятных тормозов, это браузер, мало кто заморачивается сборкой свежих версий браузера под старые платформы. Я помню похожую по скорости машину использовал для просмотра 480p и 720p видео (плеер mpv/ffplay/vlc), gentoo+awesome занимало 50мб ram, все остальное под браузер по ситуации.

Если прямо ну очень надо, можно откопать древнюю версию opera, когда у нее был свой движок (он был самый быстрый из всех), для своих локальных задач этого может хватить, но для серфинга будут проблемы с сертификатами и поддержкой браузера сайтами (никакая будет).

p.s. проверить совместимость очень легко, скачиваешь iso образы последних (потом постепенно уменьшаешь версию) linux начиная с ubuntu и пробуешь запустить (кстати с флешки загрузка в старых машинах может быть проблемной, используй 4гб флешки и пиши в режиме клонирования dd)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы