Mag1str
@Mag1str

Как вывести данные в табличную часть формы?

Есть отчет, в нем табличная часть. Как обратиться к реквизиту тч?
61e062141bdbc271410825.png
Нужно чтобы при открытии отчета он заполнялся данными с выборки
Форма
61e06238efdc3322976697.png


Код модуля формы:
&НаСервере
Процедура ПриОткрытииНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ПодпискиПользователейСрезПоследних.Пользователь КАК Пользователь,
		|	ПодпискиПользователейСрезПоследних.Подписка КАК Подписка,
		|	ПодпискиПользователейСрезПоследних.ДатаОкончания КАК ДатаОкончания
		|ИЗ
		|	РегистрСведений.ПодпискиПользователей.СрезПоследних КАК ПодпискиПользователейСрезПоследних";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		//Отчет.Подписки.ПодпискиПользователь = ВыборкаДетальныеЗаписи.Пользователь; 
		//Отчет.Подписки.ПодпискиПодписка= ВыборкаДетальныеЗаписи.Подписка; 
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПриОткрытииНаСервере();
КонецПроцедуры
  • Вопрос задан
  • 71 просмотр
Решения вопроса 2
fosihas
@fosihas
Автоматизации учета на 1С.
Взорву мозГ!!!
Можно использовать Динамический Список , на форме.

Добавляем реквизит

61e073e9ac406646272380.png
в "Настройку списка" заставляем свой запрос.

Реквизит закидываем на форму)

https://курсы-по-1с.рф/free/programming-in-1c-in-2...
Ответ написан
Mag1str
@Mag1str Автор вопроса
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НоваяСтрока =  Отчет.Подписки.Добавить();
		НоваяСтрока.Пользователь  = ВыборкаДетальныеЗаписи.Пользователь;
		НоваяСтрока.Подписка      = ВыборкаДетальныеЗаписи.Подписка; 
	КонецЦикла;
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
nki
@nki
Автоматизация бизнес-процессов.
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    //Отчет.Подписки.ПодпискиПользователь = ВыборкаДетальныеЗаписи.Пользователь; 
    //Отчет.Подписки.ПодпискиПодписка= ВыборкаДетальныеЗаписи.Подписка; 
  КонецЦикла;

Теорию учить вы принципиально не хотите?
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     новаяСтрока =  Отчет.Подписки.Добавить();
     новаяСтрока. ПодпискиПользователь = ВыборкаДетальныеЗаписи.Пользователь;
    новаяСтрока.ПодпискиПодписка= ВыборкаДетальныеЗаписи.Подписка; 
  КонецЦикла;


А лучше сделать поля в результате запроса такие же по именам, как столбца табличной части и использовать ЗаполнитьЗначенияСвойств.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы