Что идёт не так в пайпе Битбакета при сборке Laravel-приложения?

Есть приложение, которое исправно работает на сервере. Даже после переноса на другой сервер через банальный git clone + composer install - всё ок.
Попробовал впервые в жизни настроить сборку через Bitbucket pipelines. Должен делать composer install и паковать в контейнер.
Вот в контейнер пакует, а композер инсталл - не отрабатывает. Выдаёт такую вот ошибку:

+ composer install
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.
Problem 1
- php-amqplib/php-amqplib is locked to version v3.1.0 and an update of this package was not requested.
- php-amqplib/php-amqplib v3.1.0 requires ext-sockets * -> it is missing from your system. Install or enable PHP's sockets extension.
To enable extensions, verify that they are enabled in your .ini files:
- /usr/local/etc/php/php-cli.ini
- /usr/local/etc/php/conf.d/docker-php-ext-sodium.ini
- /usr/local/etc/php/conf.d/docker-php-ext-zip.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.


На обычном серваке, я бы думаю поправил php.ini или посмотрел бы что там вообще с ext-sockets. А с облачным решением в виде битбакета - хз что делать. В интернетах такой проблемы не увидел, хотя странно, никто больше не используется битбакет и amqplib? Или я что-то сильно не так делаю
  • Вопрос задан
  • 51 просмотр
Пригласить эксперта
Ответы на вопрос 1
Maksclub
@Maksclub
maksfedorov.ru
composer install --ignore-platform-reqs
Поставит, игнорируя требование расширения
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы