Как настроить mikrotik openvpn client?

есть openvpn сервер на freebsd
и есть куча openvpn клиентов с конфигом
client
dev           tun
proto         tcp
remote        00.00.00.00
port          1195
tls-client	
tls-remote    test
resolv-retry infinite
route         10.0.0.1 255.255.255.0

ca            "C:\\vpn\\ca.crt"
cert          "C:\\vpn\\client.crt"
key           "C:\\vpn\\client.key"
tls-auth      "C:\\vpn\\ta.key" 1
ns-cert-type server
#comp-lzo
tun-mtu      1500
mssfix       1450
verb         3

Есть микротик, хочу сделать его ещё одним openvpn клиентом.
вроде все настроил, но подключаться к серверу не хочет
в логах только
ovpn-out1: terminating... - peer disconnected
и фиг поймешь что оно значит.. может можно как то включить более расширенные логи?
  • Вопрос задан
  • 25485 просмотров
Пригласить эксперта
Ответы на вопрос 5
nimbo
@nimbo
tls в mikrotik ovpn насколько я помню нет.
ps: вообще если у вас планируются клиенты с Windows на борту - настоятельно рекомендую посмотреть в сторону SSTP. В нём есть свои прелести типа нативной поддержки и меньшего latency.
Ответ написан
@unix0 Автор вопроса
да проблема была в tls-auth
надо менять конфиг на сервере и конфиги всех клиентов(
убирать
tls-auth "C:\\vpn\\ta.key" 1
и поставить
auth SHA1
cipher BF-CBC

Возможно есть другой путь?
Ответ написан
LazyGatto
@LazyGatto
IT сфера
Подниму похожий вопрос. RB v. 6.27
Включил вроде как логгирование.
/system logging add topics=ovpn action=memory

Однако в логе только такие данные:
16:27:06 ovpn,info ovpn-out1: initializing...
16:27:06 ovpn,info ovpn-out1: connecting...
16:27:06 ovpn,debug ovpn-out1: disconnected
16:27:06 ovpn,info ovpn-out1: terminating... - peer disconnected

Вот настройки интерфейса:
[adminmikrotik] > /interface ovpn-client print
Flags: X - disabled, R - running
0 name="ovpn-out1" mac-address=02:EC:74:14:D6:44 max-mtu=1500 connect-to=XX.XX.XX.XX port=22 mode=ip user="none" password="" profile=default certificate=cert_2 auth=sha1 cipher=aes256 add-default-route=no

Информация по сертификатам
[adminmikrotik] > /certificate print
Flags: K - private-key, D - dsa, L - crl, C - smart-card-key, A - authority, I - issued, R - revoked, E - expired,
T - trusted
# NAME COMMON-NAME SUBJECT-ALT-NAME FINGERPRINT
1 K T cert_2 VCNbjLfR6CET 0671aff870a4f2a96...

Конфиг брался из настроек OVPN файла.
Данные в этом файле:
remote XX.XX.XX.XX
port 22
dev tun
proto tcp-client
tls-client
#tls-remote Beethoven
tls-auth ta.key 1
ca ca.crt
cert VCNbjLfR6CET.pem
key VCNbjLfR6CET.pem
comp-lzo
reneg-sec 36000
auth SHA1
cipher AES-256-CBC
keysize 256
persist-key
persist-tun
verb 3
ping 5
ping-restart 35
hand-window 150
ns-cert-type server
pull

# route-method exe
# route-delay 2
# win-sys 'env'

Сертификат pem загружен был в Mikrotik.

И никак не удается подключиться.

Дело еще в том, что доступа к серверу нет. Использовалось подключение, купленное у одного из провайдеров VPN каналов.

Может подскажете в какую сторону копать? :(
Ответ написан
ifaustrue
@ifaustrue
Пишу интересное в теллеграмм канале @cooladmin
Расширенные логи включаются из меню /system logging, далее добавляете новый вид лога
/system logging action add name=ovpn topics=ovpn
По-умолчанию логи будут сыпаться в память, максимум 1000 строк.

Кидайте лог, бум копать =)
Ответ написан
@ASPI
на сервере cipher algorithm добавить например AES 256
на клиента(на микротик) залить серт, и использовать его для аунтификации.
fb756a80d01e4ca485d1a3fd9c4be23f.jpg
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы