<types>
<type xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="type" name="AK">
<nominal>15</nominal>
<lifetime>7200</lifetime>
<category name="weapons"/>
</type>
</types>
<types>
<types xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="type" name="AK">
<nominal>15</nominal>
<lifetime>7200</lifetime>
</types>
JAXBContext.newInstance(Types.class,Category.class, ...class);
/ip firewall filter
add action=accept chain=input comment=VPN connection-state=new dst-port=\
500,1701,4500 in-interface=GARANT protocol=udp
add action=accept chain=input comment=\
"\D3\E6\E5 \EF\F0\EE\E2\E5\F0\E5\ED\ED\FB\E5 \EF\E0\EA\E5\F2\FB" \
connection-state=established,related log-prefix=ACCEPT___
add action=accept chain=forward connection-state=established,related
add action=drop chain=input comment="invalid \CF\E0\EA\E5\F2\FB" \
connection-state=invalid in-interface-list=WAN
add action=drop chain=forward connection-state=invalid in-interface-list=WAN
add action=accept chain=input comment=PING icmp-options=0:8 \
in-interface-list=WAN packet-size=100 protocol=icmp
add action=accept chain=input comment=WinBox dst-port=8291 in-interface-list=\
all protocol=tcp src-address-list=admin
add action=accept chain=forward dst-port=8443 protocol=tcp
add action=drop chain=input comment="\C2\F1\E5 \E2\F5\EE\FF\E4\F9\E8\E5 \F1 WA\
N \CD\E0 \CC\E8\EA\F0\EE\F2\E8\EA" in-interface-list=WAN log-prefix=WG1_
add action=drop chain=forward connection-nat-state=!dstnat in-interface-list=\
WAN log-prefix=qqqwww
/ip firewall mangle
add action=mark-connection chain=prerouting comment=game-Ports \
new-connection-mark=game-conn passthrough=yes protocol=udp src-address=\
192.168.100.2 src-port=2412,2302
add action=mark-packet chain=forward connection-mark=game-conn \
new-packet-mark=game-out out-interface=gre-tunnel1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=game-conn \
new-routing-mark=to-gre passthrough=no protocol=udp src-address=\
192.168.100.2
add action=mark-connection chain=prerouting comment=game-Query \
new-connection-mark=gameQ-conn passthrough=yes protocol=udp src-address=\
192.168.100.2 src-port=2316,2306
add action=mark-packet chain=forward connection-mark=gameQ-conn \
new-packet-mark=gameQ-out out-interface=gre-tunnel1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=gameQ-conn \
new-routing-mark=to-gre passthrough=no protocol=udp src-address=\
192.168.100.2
add action=mark-routing chain=prerouting comment="STEAM to GRE" \
dst-address-list=STEAM new-routing-mark=to-gre passthrough=no protocol=\
tcp src-address=192.168.100.2
add action=mark-connection chain=prerouting comment=Ditgt dst-address-list=\
DITGT new-connection-mark=dgt-conn passthrough=no
add action=mark-packet chain=forward connection-mark=dgt-conn in-interface=\
GARANT new-packet-mark=dgt-in passthrough=no
add action=mark-packet chain=forward connection-mark=dgt-conn \
new-packet-mark=dgt-out out-interface=GARANT passthrough=no
add action=mark-connection chain=prerouting comment=Web dst-port=80,443 \
new-connection-mark=web-conn passthrough=no protocol=tcp
add action=mark-packet chain=forward connection-mark=web-conn in-interface=\
GARANT new-packet-mark=web-in passthrough=no
add action=mark-packet chain=forward connection-mark=web-conn \
new-packet-mark=web-out out-interface=GARANT passthrough=no
add action=mark-connection chain=prerouting comment=OtherTCP \
new-connection-mark=otherTCP-conn passthrough=no protocol=tcp
add action=mark-packet chain=forward connection-mark=otherTCP-conn \
in-interface=GARANT new-packet-mark=otherTcp-in passthrough=no
add action=mark-packet chain=forward connection-mark=otherTCP-conn \
new-packet-mark=otherTcp-out out-interface=GARANT passthrough=no
add action=mark-connection chain=prerouting comment=No-mark \
new-connection-mark=no-mark-conn passthrough=no
add action=mark-packet chain=forward connection-mark=no-mark-conn \
in-interface=GARANT new-packet-mark=nomark-in passthrough=no
add action=mark-packet chain=forward connection-mark=no-mark-conn \
new-packet-mark=nomark-out out-interface=GARANT passthrough=no
/ip firewall nat
add action=dst-nat chain=dstnat comment=Gre-to-Lan in-interface=gre-tunnel1 \
to-addresses=192.168.100.2
add action=src-nat chain=srcnat comment="STEAM to GRE" dst-address-list=STEAM \
protocol=tcp src-address=192.168.100.2 to-addresses=100.64.1.2
add action=src-nat chain=srcnat dst-address-list=STEAM protocol=udp \
src-address=192.168.100.2 to-addresses=100.64.1.2
add action=src-nat chain=srcnat comment="ALL UDP to GRE" protocol=udp \
src-address=192.168.100.2 to-addresses=100.64.1.2
add action=dst-nat chain=dstnat comment=SQL dst-port=3306 log-prefix=\
SQL_REDIR protocol=tcp to-addresses=192.168.100.2
add action=dst-nat chain=dstnat comment=RDP/VPN dst-port=33899 in-interface=\
all-ppp protocol=tcp to-addresses=192.168.100.2
add action=dst-nat chain=dstnat comment=SVN dst-port=8443 protocol=tcp \
to-addresses=192.168.100.2
add action=src-nat chain=srcnat comment="ALL OTHER" src-address=\
192.168.100.0/24 to-addresses=111.111.111.111
Сделал. Все стало работать как надо.