@ravshan01

Как исправить несовместимость версий при установки laravel/fortify?

Всем привет, пытаюсь установить laravel/fortify.
Выводятся ошибки, как устранить несоответствия версий?

composer.json
{
    "name": "laravel/laravel",
    "type": "project",
    "description": "The Laravel Framework.",
    "keywords": [
        "framework",
        "laravel"
    ],
    "license": "MIT",
    "require": {
        "php": "^7.1.3",
        "fideloper/proxy": "^4.0",
        "laravel/framework": "5.8.*",
        "laravel/tinker": "^1.0"
    },
    "require-dev": {
        "beyondcode/laravel-dump-server": "^1.0",
        "filp/whoops": "^2.0",
        "fzaninotto/faker": "^1.4",
        "mockery/mockery": "^1.0",
        "nunomaduro/collision": "^3.0",
        "phpunit/phpunit": "^7.5"
    },
    "config": {
        "optimize-autoloader": true,
        "preferred-install": "dist",
        "sort-packages": true
    },
    "extra": {
        "laravel": {
            "dont-discover": []
        }
    },
    "autoload": {
        "psr-4": {
            "App\\": "app/",
            "Database\\": "database/"
        },
        "classmap": [
            "database/seeds",
            "database/factories"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "scripts": {
        "post-autoload-dump": [
            "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
            "@php artisan package:discover --ansi"
        ],
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "@php artisan key:generate --ansi"
        ]
    }
}


Ошибка при выполнении `composer require laravel/fortify`
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install laravel/fortify v1.7.12
    - Conclusion: don't install laravel/fortify v1.7.11
    - Conclusion: don't install laravel/fortify v1.7.10
    - Conclusion: don't install laravel/fortify v1.7.9
    - Conclusion: don't install laravel/fortify v1.7.8
    - Conclusion: don't install laravel/fortify v1.7.7
    - Conclusion: don't install laravel/fortify v1.7.6
    - Conclusion: don't install laravel/fortify v1.7.5
    - Conclusion: don't install laravel/fortify v1.7.4
    - Conclusion: don't install laravel/fortify v1.7.3
    - Conclusion: don't install laravel/fortify v1.7.2
    - Conclusion: don't install laravel/fortify v1.7.1
    - Conclusion: don't install laravel/fortify v1.7.0
    - Conclusion: remove laravel/framework v5.8.38
    - Installation request for laravel/fortify ^1.7 -> satisfiable by laravel/fortify[1.x-dev, v1.7.0, v1.7.1, v1.7.10, v1.7.11, v1.7.12, v1.7.2, v1.7.3, v1.7.4, v1.7.5, v1.7.6, v1.7.7, v1.7.8, v1.7.9].
    - Conclusion: don't install laravel/framework v5.8.38
    - laravel/fortify 1.x-dev requires illuminate/support ^8.0 -> satisfiable by illuminate/support[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.12.0, v8.12.1, v8.12.2, v8.12.3, v8.13.0, v8.14.0, v8.15.0, v8.16.0, v8.16.1, v8.17.0, v8.17.2, v8.18.0, v8.18.1, v8.19.0, v8.2.0, v8.20.0, v8.20.1, v8.21.0, v8.22.0, v8.22.1, v8.23.1, v8.24.0, v8.25.0, v8.26.0, v8.26.1, v8.27.0, v8.28.0, v8.28.1, v8.29.0, v8.3.0, v8.30.0, v8.30.1, v8.31.0, v8.32.0, v8.32.1, v8.33.0, v8.33.1, v8.34.0, v8.35.0, v8.35.1, v8.36.0, v8.36.1, v8.36.2, v8.37.0, v8.38.0, v8.39.0, v8.4.0, v8.40.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - don't install illuminate/support 8.x-dev|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.0.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.0.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.0.2|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.0.3|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.0.4|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.1.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.10.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.11.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.11.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.11.2|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.12.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.12.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.12.2|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.12.3|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.13.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.14.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.15.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.16.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.16.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.17.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.17.2|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.18.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.18.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.19.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.2.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.20.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.20.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.21.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.22.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.22.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.23.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.24.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.25.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.26.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.26.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.27.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.28.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.28.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.29.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.3.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.30.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.30.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.31.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.32.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.32.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.33.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.33.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.34.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.35.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.35.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.36.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.36.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.36.2|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.37.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.38.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.39.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.4.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.40.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.5.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.6.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.7.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.7.1|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.8.0|don't install laravel/framework v5.8.38
    - don't install illuminate/support v8.9.0|don't install laravel/framework v5.8.38
    - Installation request for laravel/framework (locked at v5.8.38, required as 5.8.*) -> satisfiable by laravel/framework[v5.8.38].


Installation failed, reverting ./composer.json to its original content.
  • Вопрос задан
  • 61 просмотр
Решения вопроса 1
alexey-m-ukolov
@alexey-m-ukolov Куратор тега Laravel
На Laravel 5.8 невозможно установить Fortify, эта библиотека поддерживает только Laravel 8.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы