besogonskiy
@besogonskiy

При попытке установить ругается на сломанные пакеты. Как вылечить linux?

Система debian Buster.

устанавливал пакет в snap но потом прервал. Теперь получаю при попытке что-нибудь установить сообщение о том, что есть сломанные пакеты. Например,

Первая ошибка
root@dev:/home/xfile/Загрузки# apt-get install kate
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
kate : Зависит: plasma-framework но он не может быть установлен
Зависит: libkf5newstuff5 (>= 5.27.0) но он не может быть установлен
Зависит: libkf5plasma5 (>= 4.96.0) но он не может быть установлен
libkf5xmlgui5 : Ломает: ktexteditor-katepart (< 5.70) но 5.54.0-1 должен быть установлен
Ломает: libkf5texteditor5 (< 5.70) но 5.54.0-1 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
root@dev:/home/xfile/Загрузки#


Или
Вторая ошибка

root@dev:/home/xfile# sudo apt install snapd
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
apparmor : Ломает: snapd (< 2.44.3+20.04~) но 2.37.4-1+b1 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
root@dev:/home/xfile#


Чего только не пробовал. Не получается никак восстановить работоспособность системы.
  • Вопрос задан
  • 163 просмотра
Пригласить эксперта
Ответы на вопрос 3
svsd_val
@svsd_val
Разработчик & администратор M$, GNU/Linux
Тут всё просто у вас есть пакеты не из бастера, вам нужно создать pref файл и указать что бастер имеет приоритеты выше чем левые репозитории и если нужно с возможностью удаления не корректных зависимостей и всё у вас заработает.
записать в файл /etc/apt/preferences.d/buster.pref
Package: *
Pin: release n=buster
Pin-Priority: 1001

Но учтите что это может понизить версии многих пакетов и часть из них могут быть удалены если нет возможности поставить их с бастера.... Либо можете поставить приоритет у другого репозитория и всё будет ставиться как укажите. В любом случае вам нужно почитать про приоритеты.
Ответ написан
@pfg21
ex-турист
поставь aptitude - интерактивная оболочка удобна, сразу видно какие пакеты сломаны. или сломаются при установке.

еще стоит глянуть в выхлоп
$ dpkg -l | grep -Pv '^ii'
показывает много чего сломанного, недоудаленного и т.д.
Ответ написан
@SquareWheel
DevOops
Просто перестаньте пользовать Дебиан. Убунта последней стейбл версии - и подобных проблем у вас не будет никогда.
Дебиан для тех, кто знает какой софт ему нужен, и предпочитает доисторические но стабильные версии.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы