flapflapjack
@flapflapjack
на треть я прав

Первый проект на Bootstrap. Какую версию использовать?

Привет.

Делаю таск менеджер, и в первый раз решил попробовать Bootstrap.

Смотрю, есть версия Beta 5. Стоит ли её использовать? Так как я в этом деле новичок, может посоветуете, какую версию стоит использовать, чтобы она была одновременно и актуальная, и проверенная.

Вообще незагуглив уже начал делать на 3.3.7, и стоит ли теперь мне вообще переезжать на более свежую версию? Если подключаю 4+ вместо 3.3.7, то верстка сразу вся едет, как и менюшки.

То, что имею сейчас, как пример: mm-tracker.sykt.tk/#
  • Вопрос задан
  • 150 просмотров
Решения вопроса 2
GTRAT
@GTRAT
Для разработки большинства веб-проектов лучше использовать последнюю версию Bootstrap. На текущий момент — это 4.6.0
Ответ написан
kawabanga
@kawabanga
Бью себя по рукам за каждый ответ на глупый вопрос
Вам уже два ответа пришло, поэтому оформлю я в виде отдельного:

1) Если учитесь, то лучше 4.X. Во всяком случае в SO или здесь всегда вам ответят.
2) 3 версию уже многие не используют много лет. Даже начинать на ней учиться - плохо. В B4 много переосмысления было интересного и красивого.
3) в 5ой версии отвязались от Jquery. Я считаю это хорошо. И даст полноценный буст для работы с JS фреймворками.

Я если бы сейчас начинал писать - то писал бы на 5ой версии. Вопрос нескольких месяцев, когда мы получим релиз.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы