@Elbakidze

Как избавиться от уязвимостей на сайте и опасно ли это?

Здравствуйте, проверил сайт через сервис хостинга бегет Aibolit — это сканер хакерских шеллов, бэкдоров, спам-рассыльщиков и других вредоносных скриптов на сайтах.
Выдает такое:
Уязвимости в скриптах (2)

public_html/wp-includes/PHPMailer/PHPMailer.php - RCE : CVE-2016-10045, CVE-2016-10031

wp-includes/class-phpmailer.php - RCE : CVE-2016-10045, CVE-2016-10031

Потом
Эти файлы могут быть вредоносными или хакерскими скриптами (9)
wp-includes/js/dist/components.min.js
и тд
что за скрипты такие и как они влияют на сайт?
  • Вопрос задан
  • 67 просмотров
Решения вопроса 1
@m0ze
The Gunner
Привет.

проверил сайт через сервис хостинга бегет Aibolit

Лучше забыть про это ПО и им не пользоваться, особенно если нет опыта в подобных вопросах: много ложных срабатываний, выявление малвари легко обходится и т.д.

Без понимания специфики работы "Ай-Болита" вы только сами себе будете на нервы действовать этими проверками, а это, в свою очередь, может подтолкнуть к глупостям вроде "самолечения" (к которому вас ещё и советчики выше подталкивают). Короче, не создавайте себе проблему на ровном месте.

Уязвимости в скриптах (2)
public_html/wp-includes/PHPMailer/PHPMailer.php - RCE : CVE-2016-10045, CVE-2016-10031
wp-includes/class-phpmailer.php - RCE : CVE-2016-10045, CVE-2016-10031

Что делает "Ай-Болит": видит PHPMailer, далее начинается "паника в селе", и он вываливает CVE в качестве предупреждения.
На самом деле: не факт, что используется именно уязвимая версия скрипта, и что файл в отчёте вообще уязвим/заражён.
По факту: CVE-2016-10045 относится к версии PHPMailer < 5.2.20, а CVE-2016-10031 вообще про Wampserver. Полагаю, перепутали с CVE-2016-10033 - PHPMailer < 5.2.18 RCE. В 2020 году "из коробки" WordPress (5.5+) использует версию PHPMailer 5.5, в которой обозначенные уязвимости закрыты.

З.Ы.: учитывая ответы выше, не вздумайте самостоятельно обновлять PHPMailer.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@vabka
Токсичный
public_html/wp-includes/PHPMailer/PHPMailer.php - RCE : CVE-2016-10045, CVE-2016-10031

wp-includes/class-phpmailer.php - RCE : CVE-2016-10045, CVE-2016-10031

Ну там же в названии видно - Php-mailer это. И там номера уязвимостей написаны - нужно его обновить.

Эти файлы могут быть вредоносными или хакерскими скриптами (9)
wp-includes/js/dist/components.min.js

Судя по названию - это что-то важное фронтовое.
Ответ написан
SagePtr
@SagePtr
Еда - это святое
Для отправки почты. В худшем случае злоумышленник сможет с вашего сервера рассылать произвольный спам. Чтобы исправить, обновите WordPress до последней версии.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы