@gingerose

Почему не работает apt-get после переустановки?

Добрый день, возникла такая проблема, после переустановки apt-get возникли сломанные пакеты.

sudo apt update работает
Сущ:1 dl.google.com/linux/chrome/deb stable InRelease
Сущ:2 ua.archive.ubuntu.com/ubuntu xenial InRelease
Сущ:3 archive.canonical.com/ubuntu xenial InRelease
Сущ:4 ua.archive.ubuntu.com/ubuntu xenial-security InRelease
Сущ:5 ua.archive.ubuntu.com/ubuntu xenial-updates InRelease
Сущ:6 ua.archive.ubuntu.com/ubuntu xenial-backports InRelease
Сущ:7 ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease
Получено 260 kB за 1с (260 kB/s)
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Все пакеты имеют последние версии.

Но когда делаю sudo apt dist-upgrade обновления, затрагивающие зависимости пакетов выходит ошибка:
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
apt-utils : Зависит: apt (= 1.6.12ubuntu0.1) но 1.8.2.2 уже установлен
aptitude : Зависит: aptitude-common (= 0.8.13-2) но он не может быть установлен
Зависит: libapt-pkg6.0 (>= 1.9.0) но он не может быть установлен
Зависит: libboost-iostreams1.74.0 (>= 1.74.0) но он не может быть установлен
Зависит: libcwidget4 (>= 0.5.18-1) но он не может быть установлен
Зависит: libgcc-s1 (>= 3.0) но он не может быть установлен
Зависит: libncursesw6 (>= 6.1+20180210) но он не может быть установлен
Зависит: libsigc++-2.0-0v5 (>= 2.8.0) но он не может быть установлен
Зависит: libstdc++6 (>= 9) но 8.4.0-1ubuntu1~18.04 уже установлен
Зависит: libtinfo6 (>= 6.1+20180210) но он не может быть установлен
Зависит: libxapian30 (>= 1.4.14~) но 1.4.5-1ubuntu0.1 уже установлен
p11-kit-modules : Зависит: libp11-kit0 (= 0.23.9-2) но 0.23.22-1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Так же пробовала делать apt --fix-broken install, sudo apt update && apt-cache policy apt-utils, sudo apt update && sudo apt -y full-upgrade, но ничего не помогло.

Кто знает, что делать в такой ситуации, буду благодарна за помощь.
  • Вопрос задан
  • 59 просмотров
Пригласить эксперта
Ответы на вопрос 1
ky0
@ky0
Миллиардер, филантроп, патологический лгун
У вас какая-то солянка из репозиториев. Выберите какую-нибудь одну версию убунты (желательно посвежее), остальные удалите, сделайте апдейт, а потом -f install.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы