Ошибка при composer update?

У меня php 8
Пытаюсь запустить команду composer update. получаю:
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires php ^7.2.5 but your php version (8.0.0) does not satisfy that requirement.
  • Вопрос задан
  • 4729 просмотров
Решения вопроса 1
composer update --ignore-platform-reqs

Или в composer.json указать новую версию php, если работать всё под ней будет в итоге.
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
@v__V__v
Разработчик
Дополню, хоть и прошло много времени, кому-то может пригодится. Есть еще вариант, можно в composer.json дополнить требования к версиям php, чтобы принимались обе ветки:
"require": {
   "php": "^7.2.5|^8.0",
...
}
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы