@mUchenik

Как обновить Deepin до версии 20?

Всех с наступающим НГ!
Желаю всем здоровья и успеха!
Знатоки, подскажите пожалуйста, как решить проблему с установкой обновлений на DEEPIN 15.11?
Суть вот в чем:
Самостоятельно система не обновлялась, при обновлении выводилась ошибка "Обновить не удалось"
На сайте нашел инструкцию по переходу на версию 20... https://mydeepin.ru/question/kak-obnovit-15-11-do-20/
Сделал как требовалось, теперь система сообщает, что обновления загружены на комп и можно обновиться, но во время установки происходит ошибка: "Обновить не удалось".
Команда:
sudo -s apt update && sudo apt upgrade -g; sudo -s apt update && sudo apt upgrade -y

Не помогает.
Что нужно сделать, что бы обновиться?
Спасибо.
  • Вопрос задан
  • 336 просмотров
Решения вопроса 1
@klepiku
то что вы делаете немного не верно
на сайте https://hackware.ru/?p=10147 есть инструкция по добавлению репозитария от другого дистрибутива

если вы совместите все вместе (додуматесь) то у вас ubuntu будет обновляться и depen то же

а легче все ручками

например так
sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak

sudo sh -c "echo 'deb https://community-packages.deepin.com/deepin/ apricot main contrib non-free' > /etc/apt/sources.list.d/depen.list"
sudo sh -c "echo 'deb https://community-store-packages.deepin.com/appstore eagle appstore ' > /etc/apt/sources.list.d/apstore.list"
sudo sh -c "echo 'Package: *'>/etc/apt/preferences.d/depen.pref; echo 'Pin: release a=Debian'>>/etc/apt/preferences.d/depen.pref; echo 'Pin-Priority: 50'>>/etc/apt/preferences.d/depen.pref"
sudo sh -c "echo 'Package: *'>/etc/apt/preferences.d/apstore.pref; echo 'Pin: release a=Debian'>>/etc/apt/preferences.d/apstore.pref; echo 'Pin-Priority: 50'>>/etc/apt/preferences.d/apstore.pref"
sudo aptitude install -t Debian ИМЯ-ПАКЕТА

и да в той инструкции не верная запись

теперь все правильно
только ключи добавить

wget https://github.com/deepin-espanol/llaves-repositor...

wget https://github.com/deepin-espanol/llaves-repositor...

wget https://github.com/deepin-espanol/llaves-repositor...

sudo cp trusted.gpg /etc/apt/

sudo cp deepin-pools-keyring.gpg uos-archive-keyring.gpg /etc/apt/trusted.gpg.d/

rm trusted.gpg deepin-pools-keyring.gpg uos-archive-keyring.gpg
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
t_q_l
@t_q_l
Интересная личность
Что значит "команда .. .не помогает"?
Какую ошибку получаете?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы