@ermolaev_nikita

Как решить проблему совместимости пакетов в PHP?

Суть проблемы проста. Допустим у нас есть какая CMS'ка, которая построена на пакетах (Prestashop, Magento, OctoberCMS и т.д.). Мы написали некоторый модуль, и используем Guzzle версии 7. К нам приходить заказчик с магазином на Prestashop (https://github.com/PrestaShop/PrestaShop/blob/deve... у которого стоит guzzle 5 версии) и говорит, установи мне свой модуль. Мы устанавливаем его, и при выполнении получаем ошибку, т.к. autoload ядра отработает и подключит свой guzzle. Мы можем в composer.json своего модуля установить prepend-autoloader = true, но тогда это приведет к некорректной работе самой CMS.

Как решить данную проблему?
  • Вопрос задан
  • 282 просмотра
Пригласить эксперта
Ответы на вопрос 1
@oxidmod
В либах не завязывайтесь на конкретные версии библиотек

зы. еще можно сделать фолбек на curl вместо газзла и все будет ок =)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы