@Nikita84q

Как правильно настроить прозрачный Squid на пару с Mikrotik?

Есть Squid-сервер (10.10.10.1) с одной сетевой картой. И есть Микротик (10.10.10.254).

Версия Сквида — 4.10. Собирал его из исходников.

На Микротике прописал правила:
/ip firewall mangle 
add chain=prerouting action=mark-routing new-routing-mark=SQUID passthrough=no 
      protocol=tcp src-address=10.10.10.100 in-interface=bridge-local
      dst-port=80
/ip route
add distance=1 dst-address=0.0.0.0/0 gateway=10.10.10.1 routing-mark=SQUID scope=30 target-scope=10

где 10.10.10.100 — адрес моего компьютера. Пока для тестов один только.

На сервере, где Squid, всё сделал по инструкциям:
iptables -t nat -A PREROUTING -i eth1 -s 10.10.10.0/24 -p tcp --dport 80 -j REDIRECT --to-ports 3129


Включил пересылку пакетов:
net.ipv4.ip_forward = 1

В настройках Сквида прописал так:
http_port 3129 intercept
http_port 3128

Всё остальное у Сквида по-умолчанию оставлено.

Когда я захожу на HTTP-сайты, страница не загружается. Индикатор бесконечно крутится, но страница не показывается. В логах Сквида посещенный сайт присутствует, но в браузере не открывается.

Иногда в логах выскакивает ошибка
1582641137.824      0 10.10.10.254 NONE/000 0 NONE error:transaction-end-before-headers - HIER_NONE/- -


В чем может быть проблема?

Сквид собран из исходников. Опции конфигурации такие:
configure options:  '--prefix=/usr' '--localstatedir=/var' '--sysconfdir=/etc/squid' '--datadir=/share/squid' '--with-default-user=proxy' '--with-logdir=/data/squid/log' '--with-pidfile=/var/run/squid.pid' '--with-swapdir=/data/squid/cache' '--with-openssl=/home/vadim/openssl-1.1.1d' '--with-large-files' '--enable-cpu-profiling' '--enable-gnuregex' '--enable-icmp' '--enable-cache-digests' '--enable-follow-x-forwarded-for' '--enable-ssl-crtd' --enable-ltdl-convenience


Можете поделиться рабочим конфигом Сквида и Микротика для 4.10 версии Сквида? Не получается настроить.
  • Вопрос задан
  • 285 просмотров
Пригласить эксперта
Ответы на вопрос 1
SignFinder
@SignFinder
Wintel\Unix Engineer
1. где правила на Mikrotik, открывающие доступ для ip squid? Вы же понимаете как работает прокси?
2. где информация о состоянии таблицы FORWARD в iptables на сервере со squid? Вы же понимаете, что net.ipv4.ip_forward = 1 недостаточно, а еще нужно разрешить прохождение пакетов в iptables?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы