@lagudal

Как установить нужную версию Varnish(4 желательно) на Centos 6?

Имеется VPS, на котором Centos 6. Установил и настроил php-fpm+mysql+nginx+magento2.
Специально для последнего хочу настроить еще Varnish + Redis.
Для сервера с теми же потребностями но под убунту все гладко, ускорение ощутимо даже невооруженным глазом. (Базовую настройку брал например из этой статьи).
На Centos 6 по умолчанию тянется версия Varnish 2 c epel, очень хотелось бы поставить 4 версию.
По официальному мануалу создаю репо, выключаю все репы кроме вновь созданной, и все равно тянется 2 с epel.
Если же в epel.repo прописываю жестко enabled=0, то yum install varnish - No package varnish available...
Что не так? Как решить? Можно еще из исходников попробовать поставить, но может что то очень простое упускаю?
В centos очень поверхностные знания, может все просто...
  • Вопрос задан
  • 72 просмотра
Пригласить эксперта
Ответы на вопрос 1
CityCat4
@CityCat4
Внимание! Изменился адрес почты!
В EL6 очень старые репы. То есть в репах софт весьма почтенного возраста. Поэтому либо искать репу, где лежит уже кем-то собранный пакет нужной версии под EL6, либо собирать самому.

Но собирать самому - это такой дэнс... В 2014 - 2015 у меня рабочая станция была как раз на EL6. И задумал я собрать что-то (уже не помню что) из исходников....
Ох, лучше бы я этого не делал...
Софт 1 заявляет, что у меня безобразно старый пакет1. Собираешь пакет1 - тот заявляет, что у меня безобразно старый пакет2. Собираешь пакет2 - ну, Вы поняли...
То, что я хотел собрать - в итоге собрал, но весь изматерился и потратил туеву хучу времени. А еще самостоятельная сборка может вылиться в порушенную систему - если не слишком представляешь, что при этом происходит (при установке, в смысле).
Я бы о смене дистриба задумался. Или там только EL6 без вариантов?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы